mac操作系统下,docker登录nexus私库,提示不支持https协议的错误

一、背景

我们使用nexus搭建了一个Docker Registry私有仓库,在Mac操作系统,在推送本地镜像到私库前,要求我们登录私库,报错如下:

bash 复制代码
docker login 192.168.5.6:8086 -u username -p password

WARNING! Using --password via the CLI is insecure. Use --password-stdin.
Error response from daemon: Get "https://192.168.5.6:8086/v2/": http: server gave HTTP response to HTTPS client

错误信息 http: server gave HTTP response to HTTPS client 表示客户端期望与服务器建立 HTTPS 连接,但服务器却返回了 HTTP 响应。这通常意味着客户端尝试通过 HTTPS 连接到一个仅支持 HTTP 的服务器。

二、nexus私库

在公司研发环境下,搭建的docker私有仓库,只支持http协议,并不涉及https证书。

一般,我们会在/etc/docker/daemon.json 配置Docker Daemon:

bash 复制代码
{
  "registry-mirrors": ["http://192.168.5.6:8087"],
  "log-driver": "json-file",
  "log-opts": {
    "max-size": "100m",
    "max-file": "3",
    "labels": "production_status",
    "env": "os,customer"
  },
  "insecure-registries" : [
    "192.168.5.6:8086",
    "192.168.5.6:8087"
  ]
}

insecure-registries 添加私库的白名单。

三、Docker Desktop

  • 官方下载dmg文件,手动安装。注意你的os版本是否符合所下载软件的要求。
    官方 Docker Desktop

  • brew安装

bash 复制代码
 brew install --cask --appdir=/Applications docker

双击并启动即可。

四、总结

如果你是通过命令行的方式更新文件/etc/docker/daemon.json,然后在docker desktop重启,并不能解决问题。

在mac操作系统下,你不能像Linux操作系统那样,使用下面的重启命令。

bash 复制代码
systemctl daemon-reload && systemctl restart docker

二者,mac用户并非root用户,你需要sudo才能写入文件/etc/docker/daemon.json。重要的是,docker desktop并不加载读取它。

所以,在docker desktop的设置中,你得找到Docker Engine的daemon配置。


此时重启docker,再次登录,就不会报错了。-- Login Succeeded

相关推荐
Lsetea3 小时前
curl指定CA目录仍报证书不受信任:--capath与OpenSSL rehash排查
运维·https·ssl·openssl·curl
优化Henry4 小时前
LTE 载波频率与频点配置详解
运维·网络·学习·5g·信息与通信
程序员清风4 小时前
Docker、Nginx 与 Kubernetes 部署 AI 后端服务
nginx·docker·kubernetes
代码方舟4 小时前
数据科学风控实战:基于天远全能消金报告构建自动化信用评估网关
运维·人工智能·自动化
科力锐品牌君4 小时前
应用级灾备 | 海量非结构化数据如何实现高效数据保护
linux·运维·网络·安全·系统安全·数据安全·灾备
KaiwuDB4 小时前
KaiwuDB 运维实战04:DRBD + KaiwuDB——物联网场景下的低成本数据库高可用方案
运维·数据库·物联网·时序数据库·kaiwudb·aiot·多模数据库
Zhu7585 小时前
离线二进制部署-Kubernetes-v1.36.4
容器·贪心算法·kubernetes
福建佰胜张工5 小时前
A5E00839230西门子工业核心配件详解:参数、安装调试与故障运维全攻略
运维·网络·安全·自动化
Lancker5 小时前
chnroute-linux — 中国大陆 IP 段每日自动更新 + 「仅允许国内访问」落地
linux·运维·tcp/ip
谢亮_vipxieliang5 小时前
镜像安全:扫描、签名与软件供应链
安全·docker