mac操作系统下,docker登录nexus私库,提示不支持https协议的错误

一、背景

我们使用nexus搭建了一个Docker Registry私有仓库,在Mac操作系统,在推送本地镜像到私库前,要求我们登录私库,报错如下:

bash 复制代码
docker login 192.168.5.6:8086 -u username -p password

WARNING! Using --password via the CLI is insecure. Use --password-stdin.
Error response from daemon: Get "https://192.168.5.6:8086/v2/": http: server gave HTTP response to HTTPS client

错误信息 http: server gave HTTP response to HTTPS client 表示客户端期望与服务器建立 HTTPS 连接,但服务器却返回了 HTTP 响应。这通常意味着客户端尝试通过 HTTPS 连接到一个仅支持 HTTP 的服务器。

二、nexus私库

在公司研发环境下,搭建的docker私有仓库,只支持http协议,并不涉及https证书。

一般,我们会在/etc/docker/daemon.json 配置Docker Daemon:

bash 复制代码
{
  "registry-mirrors": ["http://192.168.5.6:8087"],
  "log-driver": "json-file",
  "log-opts": {
    "max-size": "100m",
    "max-file": "3",
    "labels": "production_status",
    "env": "os,customer"
  },
  "insecure-registries" : [
    "192.168.5.6:8086",
    "192.168.5.6:8087"
  ]
}

insecure-registries 添加私库的白名单。

三、Docker Desktop

  • 官方下载dmg文件,手动安装。注意你的os版本是否符合所下载软件的要求。
    官方 Docker Desktop

  • brew安装

bash 复制代码
 brew install --cask --appdir=/Applications docker

双击并启动即可。

四、总结

如果你是通过命令行的方式更新文件/etc/docker/daemon.json,然后在docker desktop重启,并不能解决问题。

在mac操作系统下,你不能像Linux操作系统那样,使用下面的重启命令。

bash 复制代码
systemctl daemon-reload && systemctl restart docker

二者,mac用户并非root用户,你需要sudo才能写入文件/etc/docker/daemon.json。重要的是,docker desktop并不加载读取它。

所以,在docker desktop的设置中,你得找到Docker Engine的daemon配置。


此时重启docker,再次登录,就不会报错了。-- Login Succeeded

相关推荐
骇客野人1 小时前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
九皇叔叔4 小时前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s
蓝速科技4 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese5 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky5 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南6 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123456 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人6 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender6 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35007 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器