mac操作系统下,docker登录nexus私库,提示不支持https协议的错误

一、背景

我们使用nexus搭建了一个Docker Registry私有仓库,在Mac操作系统,在推送本地镜像到私库前,要求我们登录私库,报错如下:

bash 复制代码
docker login 192.168.5.6:8086 -u username -p password

WARNING! Using --password via the CLI is insecure. Use --password-stdin.
Error response from daemon: Get "https://192.168.5.6:8086/v2/": http: server gave HTTP response to HTTPS client

错误信息 http: server gave HTTP response to HTTPS client 表示客户端期望与服务器建立 HTTPS 连接,但服务器却返回了 HTTP 响应。这通常意味着客户端尝试通过 HTTPS 连接到一个仅支持 HTTP 的服务器。

二、nexus私库

在公司研发环境下,搭建的docker私有仓库,只支持http协议,并不涉及https证书。

一般,我们会在/etc/docker/daemon.json 配置Docker Daemon:

bash 复制代码
{
  "registry-mirrors": ["http://192.168.5.6:8087"],
  "log-driver": "json-file",
  "log-opts": {
    "max-size": "100m",
    "max-file": "3",
    "labels": "production_status",
    "env": "os,customer"
  },
  "insecure-registries" : [
    "192.168.5.6:8086",
    "192.168.5.6:8087"
  ]
}

insecure-registries 添加私库的白名单。

三、Docker Desktop

  • 官方下载dmg文件,手动安装。注意你的os版本是否符合所下载软件的要求。
    官方 Docker Desktop

  • brew安装

bash 复制代码
 brew install --cask --appdir=/Applications docker

双击并启动即可。

四、总结

如果你是通过命令行的方式更新文件/etc/docker/daemon.json,然后在docker desktop重启,并不能解决问题。

在mac操作系统下,你不能像Linux操作系统那样,使用下面的重启命令。

bash 复制代码
systemctl daemon-reload && systemctl restart docker

二者,mac用户并非root用户,你需要sudo才能写入文件/etc/docker/daemon.json。重要的是,docker desktop并不加载读取它。

所以,在docker desktop的设置中,你得找到Docker Engine的daemon配置。


此时重启docker,再次登录,就不会报错了。-- Login Succeeded

相关推荐
Ruiery7 小时前
Linux 6.6内核 CPU 深度解析(七):调度器启动 — 从单核到多核,调度器分阶段点亮
linux·运维·服务器
50万马克的面包7 小时前
CSDN-栈队列数组-知识点整理
linux·运维·服务器
MicrosoftCloud8 小时前
用户权限 04|/etc/sudoers 安全配置:从最小授权到「别把 ALL 随便给人」
运维·安全·ubuntu·sudo·sudoers
梦想不只是梦与想8 小时前
docker-compose.yml
docker·docker-compose·docker run
꯭自꯭闭꯭9 小时前
达梦事物特性及MVCC
linux·运维·数据库
亚川楼宇自控系统数据中心厂家10 小时前
实验室智能化管理系统|人环物智一体化管控平台
运维
Lsetea10 小时前
Nginx加载证书时报SSL_CTX_use_PrivateKey_file失败:私钥配对与权限排查
nginx·https·ssl证书·私钥·证书部署
zmsup12 小时前
Agent 上下文调优:结合 OpsArk 运维智能体,设计模型每一步真正需要的信息
运维·agent·上下文压缩·运维智能体·上下文调优
吴声子夜歌14 小时前
Nginx应用与运维——Nginx负载均衡应用实战(二)
运维·nginx·负载均衡
lisanmengmeng14 小时前
NRPE 添加命令(一)
linux·运维·服务器