mac操作系统下,docker登录nexus私库,提示不支持https协议的错误

一、背景

我们使用nexus搭建了一个Docker Registry私有仓库,在Mac操作系统,在推送本地镜像到私库前,要求我们登录私库,报错如下:

bash 复制代码
docker login 192.168.5.6:8086 -u username -p password

WARNING! Using --password via the CLI is insecure. Use --password-stdin.
Error response from daemon: Get "https://192.168.5.6:8086/v2/": http: server gave HTTP response to HTTPS client

错误信息 http: server gave HTTP response to HTTPS client 表示客户端期望与服务器建立 HTTPS 连接,但服务器却返回了 HTTP 响应。这通常意味着客户端尝试通过 HTTPS 连接到一个仅支持 HTTP 的服务器。

二、nexus私库

在公司研发环境下,搭建的docker私有仓库,只支持http协议,并不涉及https证书。

一般,我们会在/etc/docker/daemon.json 配置Docker Daemon:

bash 复制代码
{
  "registry-mirrors": ["http://192.168.5.6:8087"],
  "log-driver": "json-file",
  "log-opts": {
    "max-size": "100m",
    "max-file": "3",
    "labels": "production_status",
    "env": "os,customer"
  },
  "insecure-registries" : [
    "192.168.5.6:8086",
    "192.168.5.6:8087"
  ]
}

insecure-registries 添加私库的白名单。

三、Docker Desktop

  • 官方下载dmg文件,手动安装。注意你的os版本是否符合所下载软件的要求。
    官方 Docker Desktop

  • brew安装

bash 复制代码
 brew install --cask --appdir=/Applications docker

双击并启动即可。

四、总结

如果你是通过命令行的方式更新文件/etc/docker/daemon.json,然后在docker desktop重启,并不能解决问题。

在mac操作系统下,你不能像Linux操作系统那样,使用下面的重启命令。

bash 复制代码
systemctl daemon-reload && systemctl restart docker

二者,mac用户并非root用户,你需要sudo才能写入文件/etc/docker/daemon.json。重要的是,docker desktop并不加载读取它。

所以,在docker desktop的设置中,你得找到Docker Engine的daemon配置。


此时重启docker,再次登录,就不会报错了。-- Login Succeeded

相关推荐
YH行业报告分析2 小时前
2026电缆铺设设备市场:自动化敷设与电网升级驱动增长
运维·自动化
Wang's Blog2 小时前
Java 项目部署之 Docker工具快速入门: Docker 是什么以及它如何解决部署环境问题
java·开发语言·docker
ajassi20003 小时前
AI语音智能体开发日记(十八)智能体服务器xiaozhi-esp32-server源码部署指南
运维·服务器·人工智能·ai·ai编程
‎ദ്ദിᵔ.˛.ᵔ₎3 小时前
linux 进程信号(下)
linux·运维·服务器
Mikko73 小时前
Linux 磁盘满了但 du 找不到?LVM 扩容 df 不变?fstab 写错开不了机?三台真机实测磁盘排查
linux·运维·centos
蓝胖的四次元口袋3 小时前
Jenkins知识梳理(2)
运维·jenkins
yumgpkpm3 小时前
Acceldata ODP 3.3.6.4 vs CDP Private Cloud Base 7.3.2 对比
大数据·运维·服务器·hadoop·华为·zookeeper·hbase
AIGC大时代3 小时前
LLM Agent 执行沙箱闸门:失败含义与当天最小实验
docker·沙箱·闸门·bubblewrap·llm agent
Liuqy-053 小时前
特殊进程——孤儿、僵尸、守护进程
linux·运维·服务器