Unable to find a node that satisfies the following conditions [port xxxx]

Unable to find a node that satisfies the following conditions port xxxx

原因:当容器使用端口映射(docker run -p xxxx:xxxx或 compose模板中的

ports)之后 系统会在宿主机上创建一个port,通过NAT来访问容器的指定port。如果宿主机上的端口被容器或者系统进程占用,就会导致端口分配失败。

解决方式:

清除占用端口的容器或者进程,或调整容器端口映射的宿主机端口避免冲突

Docker是一种相对使用较简单的容器,我们可以通过以下几种方式获取信息:

1、通过docker run执行命令,或许返回信息

2、通过docker logs 去获取日志,做有针对性的筛选

3、通过systemctl status docker查看docker服务状态

4、通过journalctl -u docker.service 查看日志

完整版故障总结请移步查看:

链接: 点赞收藏呀

相关推荐
菜_小_白27 分钟前
codex
linux·vscode·ai
程序员老赵30 分钟前
Docker 部署 Dolibarr:轻松搭建开源 ERP/CRM 平台
运维·前端·后端
zhangrelay37 分钟前
用ROS2Lyrical实验报告册思路重做蓝桥云课ROS1实验并改进
linux·笔记·学习·ubuntu·机器人
林兴洋44 分钟前
linux-mtr命令-ping和traceroute的能力合二为一
linux
cws2004011 小时前
监控摄像头选型指南
运维·网络·监控
协皓家具1 小时前
2026年广州岛台吧台椅厂家有啥新变化
大数据·运维·python·devops
OsDepK1 小时前
OSMDE_v1.9.0已加入FTP与shell功能
linux·运维·服务器
和裕1 小时前
定制纸箱刀模费全解析:费用定义与可减免合作场景
大数据·运维·网络·人工智能·算法
吴声子夜歌2 小时前
Nginx应用与运维——Nginx集群负载与配置管理(二)
运维·nginx
硅基手札2 小时前
【Linux内核专栏 11】驱动框架:platform / char / misc / 设备树
linux·运维·服务器