Codeforces远古场 Longest Regular Bracket Sequence (动态规划)

Longest Regular Bracket Sequence

题面翻译

给出一个括号序列,求出最长合法子串和它的数量。

合法的定义:这个序列中左右括号匹配

题目描述

This is yet another problem dealing with regular bracket sequences.

We should remind you that a bracket sequence is called regular, if by inserting <<+>> and <<1>> into it we can get a correct mathematical expression. For example, sequences <<(())()>>, <<()>> and <<(()(()))>> are regular, while <<)(>>, <<(()>> and <<(()))(>> are not.

You are given a string of <<(>> and <<)>> characters. You are to find its longest substring that is a regular bracket sequence. You are to find the number of such substrings as well.

输入格式

The first line of the input file contains a non-empty string, consisting of <<(>> and <<)>> characters. Its length does not exceed $ 10^{6} $ .

输出格式

Print the length of the longest substring that is a regular bracket sequence, and the number of such substrings. If there are no such substrings, write the only line containing "0 1".

样例 #1

样例输入 #1

)((())))(()())

样例输出 #1

6 2

样例 #2

样例输入 #2

))(

样例输出 #2

0 1

考虑这道题的DP方法。

不难想出,要用 f [ i ] f[i] f[i] 来表示前 i i i 段里面最长的合法括号序列,现在来考虑能够怎么DP。

合法的序列可以有以下两种情况:

  • ((())),也就是单个大括号
  • ()()(()),也就是多个括号

那么对于单个大括号当然就很好维护,他的长度就可以算为最右边的右括号的下表减去最左边的左括号的下表加1,在这种情况下不需要状态转移。

对于多个括号的情况,我们要考虑状态转移。

由于我们在维护段落的合理性的时候是通过栈来维护的,我们用以下变量来实现数组模拟栈stk[N]为栈本身 tt为栈顶,在检测到左括号的时候我们会压入他的下标,那么取出的时候一定是最左边的右括号先去对应最右边的左括号,知道堆中元素全部弹出。

那么我们可以每次检查一下f[stk[tt] - 1]是否有元素,如果有的话就说明了当前右括号对应的左括号的左边是有另一组合理括号段的,那么就加上他。

因为题目要求要记录数量,所以我们使用cnt数组进行各个段落的最长合理子段的数量记录。

那么最终的状态转移方程就是:++cnt[f[i] = i - stk[tt] + 1 + f[stk[tt--] - 1]]


CODE:

cpp 复制代码
#include<bits/stdc++.h>
using namespace std;
const int N = 1e6 + 10;
#define endl '\n'

int stk[N];
int tt = -1;
int f[N];
int cnt[N];

int main(){
    string s;cin >> s;
    for(int i = 0;i < s.size();i++){
        if(s[i] == '(')stk[++tt] = i;
        else if(~tt) ++cnt[f[i] = i - stk[tt] + 1 + f[stk[tt--] - 1]];
    }
    cnt[0] = 1;
    for(int i = s.size();~i;i--){
        if(cnt[i]){
            cout << i << " " << cnt[i] << endl;
            return 0;
        }
    }
    return 0;
}
相关推荐
limingade1 小时前
手机实时提取SIM卡打电话的信令和声音-新的篇章(一、可行的方案探讨)
物联网·算法·智能手机·数据分析·信息与通信
jiao000014 小时前
数据结构——队列
c语言·数据结构·算法
迷迭所归处5 小时前
C++ —— 关于vector
开发语言·c++·算法
leon6255 小时前
优化算法(一)—遗传算法(Genetic Algorithm)附MATLAB程序
开发语言·算法·matlab
CV工程师小林5 小时前
【算法】BFS 系列之边权为 1 的最短路问题
数据结构·c++·算法·leetcode·宽度优先
Navigator_Z6 小时前
数据结构C //线性表(链表)ADT结构及相关函数
c语言·数据结构·算法·链表
Aic山鱼6 小时前
【如何高效学习数据结构:构建编程的坚实基石】
数据结构·学习·算法
天玑y6 小时前
算法设计与分析(背包问题
c++·经验分享·笔记·学习·算法·leetcode·蓝桥杯
sjsjs117 小时前
【数据结构-一维差分】力扣1893. 检查是否区域内所有整数都被覆盖
数据结构·算法·leetcode
redcocal7 小时前
地平线秋招
python·嵌入式硬件·算法·fpga开发·求职招聘