docker容器内时区相差8小时问题

docker容器内时区相差8小时问题:

提示:java 时间记录差*小时:


进入容器内修改(已经实践过的)

(1)更改容器时间

也就是操作的文件夹是容器内的文件夹,不再是宿主机的

首先是从宿主机进入容器,输入以下命令(containerID就是我们在宿主机通过docker ps -a获取到的容器id值):

bash 复制代码
docker exec -it containerID /bin/bash

进入容器后,我们ls即可看到已经进入容器内部,容器内部的文件目录和我们的linux目录是一样的(退出容器是exit),我们输入以下命令进行修改:

bash 复制代码
ln -sf /usr/share/zoneinfo/Asia/Shanghai /etc/localtime
相关推荐
蓝速科技9 分钟前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese38 分钟前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky1 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南2 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123452 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人2 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender2 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35003 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南3 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
春天花会开1314 小时前
Supabase 自部署 Edge Functions 超时从 60s 延长到 360s 完整复盘
运维·云原生