大量worker process is shutting down导致nginx服务器请求异常

现象:生产环境网站接口监控报大量超时告警

排查:

查看是否属于异常攻击

1、查看公网slb带宽使用情况

2、查看nginx日志,看是否有异常流量

查看服务器及服务状态

1、查看nginx服务器资源cpu使用情况

2、查看nginx服务状态(ps -ef|grep nginx)

发现大量worker process is shutting down的进程状态

原因分析

复制代码
nginx新配置了一个域名,有websocket的长连接,生产发布时,nginx热加载reload后,长连接一直处于连接中未断开,导致nginx reload的时候一直处于这个状态,把系统负载打满了

解决:

复制代码
nginx.conf配置文件中增加worker_shutdown_timeout 10;
相关推荐
虎头金猫2 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
还是大剑师兰特2 天前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
xing-xing2 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅2 天前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog2 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发
琥珀色糖2 天前
SimlpeHttp
linux·服务器
第十人i2 天前
Linux 日志管理系统:journald 配置与优化
linux·服务器
ITxiaobing20232 天前
IP 定位服务选型指南:从准确率到工程落地的技术考察
linux·服务器·网络
wuyk5552 天前
【Socket 进阶之路】第 9 章 Linux 网络服务量产稳定性优化|心跳保活、TIME_WAIT、SO_LINGER、内存池、断线重连、完整异常防护框架
linux·服务器·开发语言·网络·物联网
Julien20042 天前
Docker 容器存储原理(一)
linux·运维·服务器·ssh·学习方法