Kafka内外网分流配置listeners和advertised.listeners

问题背景:

Kafka部署在内网,内网Java服务会使用Kafka收发消息,另外,Java服务会与其他第三方系统使用kafka实现数据同步,也就是外网也会发送消息到kafka,外网IP做了端口映射到了内网,advertised.listeners配置了外网ip端口,所以这里的问题就是内网程序发送kafka消息也会走到外网,这样会有部分连接出现超时错误,所以这种方式不太合理。

解决办法:

参考网上内外网分流方式进行处理,外部访问kafka通过公网连接,内部程序使用内网访问。

listeners与advertised.listeners含义

1. listeners

含义 :用于指定Kafka Broker实际监听的地址和端口,listeners 的格式通常是:协议名称://主机名或IP地址:端口,可以同时配置多个, 并且用逗号隔开,监听器的名称和端口必须是唯一的,端口相同,就冲突了。
示例:

复制代码
listeners=PLAINTEXT://your.host.name:9092

在这个示例中,Kafka Broker将监听your.host.name这个主机名上的9092端口,并使用PLAINTEXT协议(即不加密的文本协议)。

2.advertised.listeners

含义 :

Kafka 服务器对外宣传的端点信息,它会将地址注册到Zookeeper中,用于告诉客户端应该连接到哪个地址和端口,也就是客户端真正要访问的地址。advertised.listeners 的格式与 listeners 类似,但是可以指定不同的地址或端口,如果没有配置,则默认值和listener一样,另外,advertised.listeners不支持0.0.0.0这种形式, 所以如果listeners属性设置成0.0.0.0,则必须设置advertised.listeners属性。
示例:

复制代码
listeners=PLAINTEXT://internal.host.name:9092  
advertised.listeners=PLAINTEXT://external.host.name:9092

在这个示例中,Kafka Broker在内部网络上监听internal.host.name这个主机名上的9092端口,但向外部客户端公布external.host.name这个主机名上的9092端口作为连接地址。

内外网分流配置修改

kakfa配置文件config/server.properties修改前:

复制代码
listeners=PLAINTEXT://172.20.0.147:9092
advertised.listeners=PLAINTEXT://10.103.25.230:9092

修改后:

复制代码
listeners=INSIDE://:19092,OUTSIDE://:9092
advertised.listeners=INSIDE://172.20.0.147:19092,OUTSIDE://10.103.25.230:9092
listener.security.protocol.map=INSIDE:PLAINTEXT,OUTSIDE:PLAINTEXT
inter.broker.listener.name=INSIDE

说明:

  • listeners这里设置了2个监听器,监听了所有IP的两个端口,19092为内网kafka使用端口,9092为外部访问端口
  • 172.20.0.147是内网服务器IP地址,10.103.25.230为公网IP地址,端口已也添加了映射:10.103.25.230->172.20.0.147,这样我们当我们通过kafka客户端连接kafka时,kafka会从zookeeper中获取kafka元数据信息,这时候kafka客户端得到的就是advertised.listeners的信息,因为这里OUTSIDE配置的外网IP,当客户端通过10.103.25.230访问kafka时,请求就会被之前配置的映射进行转发,被转发到内网ip,从而完成对kafka的访问。
  • listener.security.protocol.map为监听器名称和安全协议之间的映射关系集合,PLAINTEXT表示明文
  • inter.broker.listener.name用于broker之间通信的listener名称,如果未设置,则listener名称由 security.inter.broker.protocol 定义(security.inter.broker.protocol默认值是PLAINTEXT)

遇到问题

  1. 修改过程中的报错:
powershell 复制代码
org.apache.kafka.common.KafkaException: Socket server failed to bind to 10.103.25.230:9092: Cannot assign requested address.

解决方案 :

将listeners由原来固定IP修改为:

powershell 复制代码
listeners=INSIDE://:19092,OUTSIDE://:9092

参考链接:
https://juejin.cn/post/6893410969611927566
https://www.confluent.io/blog/kafka-listeners-explained/

相关推荐
小羊没烦恼!3 天前
微服务化的基石——持续集成
java·大数据·word·powerpoint·.net
俊昭喜喜里3 天前
java中的继承和多态的区别
java
小羊没烦恼!3 天前
初探性能优化——2个月到4小时的性能提升
java·开发语言·windows·算法·c#
譕痕3 天前
JSONObject与JSONArray封装数据格式区别
java·json
胡写代码3 天前
别再前后端各写一套表单校验了
java·后端
小鱼能吃糖3 天前
缺陷修复总览 · mall电商项目:5类缺陷,1个病根,4个业务域
java·电商
此时不提桶,更待何时3 天前
01-06-A-JVM排查实战详解
java·jvm
vipxieliang3 天前
ValidX 在 DDD 领域驱动设计中的实践
java·spring boot
ba_pi3 天前
mysql 查询所有表名并授权
java
ProcessOn官方账号3 天前
java函数式编程--入门基础
java·编程·函数式编程