【K8s】【问题排查】k8s只能本地服务器访问服务,其他节点无法访问服务

出现原因:

问题描述:k8s部署服务之后,只能在Pod所在的节点通过node ip+ 对外暴露的端口请求;无法使用CLUSTER-IP+端口访问。也不能在其他Node节点通过Pod所在的节点通过node ip+ 对外暴露的端口请求;

主机名与IP对应情况:

主机名 IP
192.168.199.201 k8s-01
192.168.199.202 k8s-02
192.168.199.203 k8s-03

服务部署情况:

bash 复制代码
kubectl get svc
#显示
NAME             TYPE        CLUSTER-IP     EXTERNAL-IP   PORT(S)        AGE
nginx-dep1       NodePort    10.10.42.233   <none>        80:30692/TCP   24s
bash 复制代码
kubectl get pods -o wide
#显示
NAME                                            READY   STATUS      RESTARTS   AGE     IP                NODE     NOMINATED NODE   READINESS GATES
nginx-dep1-9bcf54c77-l8wz7                      1/1     Running     0          8m38s   10.122.165.234    k8s-03   <none>           <none>
复制代码
通过上述内容,我们不难发现。服务nginx-dep1部署在k8s-03节点,IP为192.168.199.203。

地址请求测试

服务器 请求地址 是否成功
192.168.199.201、192.168.199.202、192.168.199.203 10.10.42.233 失败
192.168.199.201、192.168.199.202 192.168.199.203:30692 失败
192.168.199.203 192.168.199.203:30692 成功

报错信息:

shell 复制代码
curl: (7) Failed connect to 192.168.199.203:30692; Connection timed out

排查过程:

  1. 排查是否关闭防火墙
    检查已经关闭
  2. 查找Kubernetes相关资料发现,node节点有请求转发,我们需要查看是否开启请求转发
bash 复制代码
iptables --list | grep 'Chain FORWARD'
#显示
Chain FORWARD (policy DROP)
复制代码
出现Chain FORWARD (policy DROP)表示请求转发被关闭。需要开启。

解决方案:

shell 复制代码
iptables -P FORWARD ACCEPT
#为了防止重启再次关闭,填写配置
echo net.ipv4.ip_forward=1 >>/etc/sysctl.conf 

验证:

bash 复制代码
iptables --list | grep 'Chain FORWARD'
#显示
Chain FORWARD (policy ACCEPT)
相关推荐
虎头金猫5 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
-梅5 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)5 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
Wang's Blog5 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发
guo_wen_qiang5 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren5 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
琥珀色糖5 天前
SimlpeHttp
linux·服务器
第十人i5 天前
Linux 日志管理系统:journald 配置与优化
linux·服务器
ITxiaobing20235 天前
IP 定位服务选型指南:从准确率到工程落地的技术考察
linux·服务器·网络
wuyk5555 天前
【Socket 进阶之路】第 9 章 Linux 网络服务量产稳定性优化|心跳保活、TIME_WAIT、SO_LINGER、内存池、断线重连、完整异常防护框架
linux·服务器·开发语言·网络·物联网