一种docker start放回Error response from daemon: task xxx错误的解决方式

1. 问题描述

执行systemctl daemon-reload与systemctl restart docker命令后,发现docker中有的应用无法启动,并显示出Exit(255)的错误提示。

重新执行docker start 容器id后发现返回,Error response from daemon: task xxx的错误。

2. 问题解决

由于容器中包含文件、数据、配置等内容,无法直接删除并新建一个容器,而且当前系统中运行这其他服务,也无法重启,故尝试排除启动容器时所产生的报错。

使用ps aux查询所有进程发现,存在如下进程:

root 136141 0.3 0.0 111828 9720 ? Sl 17:56 0:00 /usr/bin/containerd-shim-runc-v2 -namespace moby -id 40c463664dfc9ac7ea3f73a1179af93c1528926a204217bc6ba6a753b5ce3bce -address /run/containerd/containerd.sock

该进程的id,同容器id相同,怀疑因为冲突,故无法正常启动。

使用kill -9强行杀死该进程后,再使用docker start,容器正常启动,问题解决。

相关推荐
小此方31 分钟前
Linux网络(十九):TCP流量控制与滑动窗口详解,超时重传和快重传到底有什么区别
linux·运维·服务器·网络·网络协议·tcp/ip
海宇服务39 分钟前
零信任架构实战:基于海宇运营商近3个月欠费次数构建自动化履约能力评估管线
运维·人工智能·架构·自动化
码上有光1 小时前
Linux进程通信——共享内存、消息队列和信号量
android·linux·运维·共享内存·通信
沫璃染墨1 小时前
《从零入门Linux系统篇(五十四):线程篇·七——互斥锁底层原理:从原子交换到线程竞争与锁实现》
linux·运维·服务器·开发语言·c++·驱动开发·系统架构
志栋智能1 小时前
超自动化巡检中的异常检测与根因分析
运维·自动化
吴声子夜歌1 小时前
Nginx应用与运维——Nginx HTTP模块详解(访问控制功能模块)
运维·nginx·http
Ruiery2 小时前
Linux 6.6内核 CPU 深度解析(一):BSP 拉起 — 从实模式到 kernel_init 的完整旅程
linux·运维·服务器
赵民勇2 小时前
dconf命令详解
linux·运维
代码方舟2 小时前
零信任架构实战:基于天远学历信息高级版构建自动化智库入驻审查网关
运维·人工智能·架构·自动化
和裕3 小时前
年度框架直供 vs 零散按需采购:定制纸箱采购成本、交付与服务核心区别全对比
大数据·运维·网络·人工智能·算法