Ubuntu 18.04安装Samba服务器及配置

1、samba服务器搭建(ubuntu)

(2)安装samba服务器

sudo apt-get install samba samba-common smbclient

解决

sudo locale-gen en_US.UTF-8

sudo update-locale LANG=en_US.UTF-8

#可能会报错,/usr/local/lib/locale/ 这个目录不存在则新建
cd /var/lib/dpkg/info

rm -rf samba*

(3)创建一个用于分享的samba目录。
sudo mkdir /data/share

(4)给创建的这个目录设置权限
sudo chmod 777 /data/share

(5)添加用户(下面的lys是我的用户名,之后会需要设置samba的密码)。
sudo smbpasswd -a lys

(如果无法创建,则先执行第6步)

(6)配置samba的配置文件。
sudo vim /etc/samba/smb.conf

109-lys

comment = share folder

browseable = yes

path = /home/lys/data

create mask = 0700

directory mask = 0700

valid users = lys

force user = lys

force group = lys

public = yes

available = yes

writable = yes

上述配置没有写的权限(用户名为:user),修改成下面解决问题

复制代码
[203-lys]
comment = share folder
browseable = yes
#path = /data1/20-7/lys
path = /home/user/work/share
read only = no
create mask = 0700
directory mask = 0700
valid users = user
force user = nobady
force group = nogroup
public = yes 
available = yes 
writable = yes

(7)重启samba服务器。

sudo service smbd restart -- (ok)

sudo /etc/init.d/smbd restart --(ok)

sudo systemctl start smb / sudo systemctl start smbd / sudo systemctl start samba
sudo systemctl status smbd.service (ok)

sudo systemctl status smbd ---(ok )

service smb status

错误:

Failed to start smbd.service: Unit smbd.service is masked.

尝试

复制代码
sudo systemctl unmask smbd
sudo systemctl enable smbd
sudo systemctl restart smbd

2、windows访问

通过\\+ ip的方式访问,可以在linux中通过命令 ifconfig命令查看ip地址

输入地址后,我们应该就可以看到share文件夹了,进入share文件夹可以看到我们共享的文件目录

五、映射到磁盘

为了更方便地使用,我们可以将samba服务器映射到磁盘,

1.打开此电脑界面,点击映射网络驱动选项

2.在文件夹选项中输入对应的路径

文件夹填:\\ip\203-lys

3.点击确定,即可在计算机界面看见映射成功的磁盘了

参考:使用samba服务器在windows下访问linux的文件_windows访问linux共享文件 smb-CSDN博客

------------------------------------------------------------

输出日志。

smbd -F -S

sudo mkdir -p /var/log/samba/cores

sudo chmod -R 0700 /var/log/samba/cores

#--------------------------------------------------------centos安装-----------

lsb_release -a
Centos
yum install samba samba-common

Failed to start smb.service: Unit smb.service not found报错解决方法

sudo systemctl enable smb

sudo systemctl start smb

有效

安装samba后,完成共享目录配置,提示"无权限,请联系管理员"

尝试修改文件夹的权限并不起作用,

查阅samb文档后发现是文件夹安全性的设置问题

执行命令sudo chcon -R -t samba_share_t /Path/to/directory(共享目录具体路径)

解决问题

查看状态

service smb status

相关推荐
EasyGBS38 分钟前
摄像头还在线,画面已经不能用了?国标GB28181视频平台EasyGBS视频质量诊断怎么用
服务器·安全·音视频
程序员-Benothing1 小时前
Vim编辑器从入门到精通:模式、快捷键、配置、插件
linux·运维·服务器
wdfk_prog1 小时前
LWIP教程 09:从 `tcp_slowtmr()` 到 Fast Retransmit——TCP 超时重传与重复 ACK
服务器·网络·数据库·网络协议·tcp/ip
‎ദ്ദിᵔ.˛.ᵔ₎1 小时前
linux 进程信号 (上)
linux·服务器
15Moonlight1 小时前
Linux网络(02):Socket 编程 UDP
linux·网络·udp
迪康Defender1 小时前
终端安全审批体系设计:如何平衡安全管控与业务连续性
运维·服务器·安全·运维开发·学习方法·业界资讯·远程工作
wuminyu2 小时前
ForkJoinPool窃取线程在扫描其他WorkQueue时的随机采样算法与Phase线程挂起唤醒机制解析
java·linux·c语言·jvm·c++
liulilittle2 小时前
Linux 下 select 测试函数
linux·服务器·网络·数据库·c++·select·c