题目描述
奶牛们按不太传统的方式玩起了小孩子们玩的"跳房子"游戏。奶牛们创造了一个5x5的、由与x,y轴平行的数字组成的直线型网格,而不是用来在里面跳的、线性排列的、带数字的方格。然后他们熟练地在网格中的数字中跳:向前跳、向后跳、向左跳、向右跳(从不斜过来跳),跳到网格中的另一个数字上。他们再这样跳啊跳(按相同规则),跳到另外一个数字上(可能是已经跳过的数字)。一共在网格内跳过五次后,他们的跳跃构建了一个六位整数(可能以0开头,例如000201)。
求出所有能被这样创造出来的不同整数的总数。
输入
第1到5行: 题面中的网格,一行5个整数
输出
第1行: 能构建的不同整数的总数
样例输入
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1
样例输出
15
AC代码:
cpp
#include<bits/stdc++.h>
using namespace std;
int cnt;
string ans;
char mp[11][11];
int dir[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};
bool in(int x, int y) {
return 1 <= x && x <= 5 && 1 <= y && y <= 5;
}
set<string> s;
void dfs(int x, int y, int dep, string an) {
an += mp[x][y];
if (dep == 6) {
if (!s.count(an)) {
s.insert(an);
cnt++;
}
return;
}
for (int i = 0; i < 4; i++) {
int nx = x + dir[i][0], ny = y + dir[i][1];
if (in(nx, ny)) {
dfs(nx, ny, dep + 1, an);
}
}
return;
}
int main() {
for (int i = 1; i <= 5; i++)
for (int j = 1; j <= 5; j++)
cin >> mp[i][j];
for (int i = 1; i <= 5; i++) {
for (int j = 1; j <= 5; j++) {
dfs(i, j, 1, "");
}
}
cout << cnt << endl;
return 0;
}