K8s中pod控制器

一.pod的控制器:又叫工作负载workload,介于k8s集群和节点之间。中间层,确保pod资源符合预期的状态;pod资源出现故障的时候,会自动重启;对于基于控制器创建的pod,delete pod相当于对pod进行了重启,并不会删除pod;删除pod必须要删除控制器deployment,pod就会自动删除

二.pod控制器的类型:基于控制器创建的pod,只删除pod相当于重启pod

1.replicaset:结合控制一块,控制副本数量

2.deployment:最常见,也是最好用的控制器,用于应用型pod因为是要对外访问的。

3.daemonset:确保在每个节点上都会部署一个pod,主要用于后台的支撑业务;特性:服务是无状态应用(pod的名称是不固定的);delete pod也相当于重启;需要在每个节点都部署,或者是需要在后台运行的pod,相当于elk,daemonset不能指定副本数,因为它本身就会在每个节点部署一个pod。

4.statefulset:有状态的部署,pod的名称是固定的,一旦创建永久不变,即使增加副本数,也是有序的递增;可以指定副本数;pod可以扩容和缩容;delete pod也是相当于重启pod,只不过pod的名称不在发生变化。主要用于数据库,数据库必须要指定的编号,对数据独立性要求比较高的应用尤其是数据库及redis。Cluster ip必须要为空;基于statefulset无头服务headless;有名称的副本需要持久化存储,每个pod都有一个独立的挂载卷;生产过程中动态pv自动给每个pod创建一个挂载卷。

所有的pod都会自动生成一个pv,在存储节点目录创建一个独立的数据卷,不能作为统一的数据同步到容器。

delete其中一个pod'后pod名称不会改变,但是IP会发生变化

三、job控制器不属于以上控制器的范围,它是任务型控制器:分为普通任务和定时任务;批量处理脚本,数据库迁移,视频解码一次性任务;需要定期执行任务,环境扫描,健康检查。

普通类型job vim job.yml

定时任务类型:cronjob.yml

刚开始看不到,因为1分钟才执行

相关推荐
九皇叔叔9 小时前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s
蓝速科技9 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese10 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky10 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南11 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我1234511 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人11 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender12 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly350012 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南13 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台