firewalld实现NAT端口转发

1、准备工作

# 开启 NAT 转发

firewall-cmd --permanent --zone=public --add-masquerade

# 开放 DNS 使用的 80 端口,tcp# 必须,否则其它机器无法进行域名解析

firewall-cmd --zone=public --add-port=80/tcp --permanent

# 检查是否允许 NAT 转发

firewall-cmd --query-masquerade# 禁止防火墙 NAT 转发

firewall-cmd --remove-masquerade

2、 NAT 端口转发

端口转发可以将++++指定地址访问指定的端口++++** 时,将流量转发至**++++指定地址的指定端口++++。转发的目标如果不指定ip的话就默认为本机,如果指定了ip却没指定端口,则默认使用来源端口。

2.1 将80端口的流量转发至8080

firewall-cmd --add-forward-port=port=80:proto=tcp:toport=8080 --permanent

2.2 将80端口的流量转发至192.168.0.1

firewall-cmd --add-forward-port=proto=80:proto=tcp:toaddr=192.168.0.1 --permanent

2.3 将80端口的流量转发至192.168.0.1的8080端口

firewall-cmd --add-forward-port=proto=80:proto=tcp:toaddr=192.168.0.1:toport=8080 --permanent

注意:nat端口转发完以后,一定要用"firewall-cmd --reload"重新加载配置才会真正的生效。

"--permanent"代表永久的意思,重启后同样会生效。

如果配置完以上规则后仍不生效,检查防火墙是否开启80端口,如果80端口已开启,仍无法转发,可能是由于内核参数文件sysctl.conf未配置ip转发功能,具体配置如下:

vim /etc/sysctl.conf

net.ipv4.ip_forward = 1

保存文件后,输入命令:"sysctl -p" 生效!

3、关闭NAT端口转发

#查看状态:

firewall-cmd --state

#删除开放的80端口

firewall-cmd --zone=public --remove-port=80/tcp --permanent

#删除nat端口转发(本机80转到192.168.0.1:8080)

firewall-cmd --remove-forward-port=proto=80:proto=tcp:toaddr=192.168.0.1:toport=8080 --permanent

#列出所有的规则

firewall-cmd --list-all

相关推荐
殷色玫瑰12 分钟前
C/C++ 内存管理详解:从内存分布到 new/delete 底层原理
java·linux·c语言·c++
꯭自꯭闭꯭1 小时前
DM7主备升级方案
linux·服务器·数据库
用户4107192013251 小时前
VMware 虚拟机Ubuntu 环境linux远程连接失败
linux
lisanmengmeng2 小时前
Nagios邮件报警的配置
linux·运维·服务器
Ruiery2 小时前
Linux 6.6内核 CPU 深度解析(六):cpufreq
linux·运维·服务器
倔强的石头1062 小时前
【Linux指南】动静态库系列(十一):PLT 与延迟绑定:第一次调用动态库函数时发生了什么
linux·人工智能·python
硅基手札3 小时前
【linux内核专栏 08】时间与定时器
linux·运维·服务器
想做小南娘,发现自己是女生喵3 小时前
Linux之Ubuntu入门篇知识总结
linux·运维·服务器
life码农3 小时前
Nginx 配置允许指定 IP 段访问:从 192.168.1.1 到 192.168.1.124 及 /24 详解
网络·tcp/ip·nginx
javaDocker3 小时前
16.5 小时,我打掉了两只「SSL 握手失败」的怪
网络·网络协议·ssl