Linux FTP服务问题排查

一、问题描述

最近linux虚拟机重启之后发现,FTP服务总是不正常,工具无法连接。

二、排查及处理过程

1、检查ftp服务是否正常安装:yes

rpm -qa|grep vsftpd

2、检查ftp服务是否正常启动:

systemctl status vsftpd

启动vsftpd

systemctl start vsftpd

3、使用连接工具测试

MobaXterm FTP连接不成功,提示:

<<< 530 Please login with USER and PASS.

Error EElFTPSUnacceptedReplyError: Unaccepted server reply code 530 to command PWD

错误代码530通常表示用户没有登录或者登录失败,服务器因为权限问题拒绝了用户的登录请求。

原因:root用户没有配置ftp对应的路径和权限。

更改root用户登录成功:

Opening FTP connection to 192.168.146.130

FTP login with username ftpuser

<<< 220 (vsFTPd 3.0.2)

>>> USER ftpuser

<<< 331 Please specify the password.

>>> PASS ***********

<<< 230 Login successful.

>>> FEAT

<<< 250 Directory successfully changed.

>>> PWD

<<< 257 "/usr/ftproot"

>>> CWD /usr/ftproot

<<< 250 Directory successfully changed.

>>> PWD

<<< 257 "/usr/ftproot"

Opening directory /usr/ftproot...

>>> PWD

<<< 257 "/usr/ftproot"

>>> CWD /usr/ftproot

<<< 250 Directory successfully changed.

>>> TYPE A

<<< 200 Switching to ASCII mode.

>>> PASV

<<< 227 Entering Passive Mode (192,168,146,130,207,32).

>>> LIST

<<< 150 Here comes the directory listing.

<<< 226 Directory send OK.

>>> CWD /usr/ftproot

<<< 250 Directory successfully changed.

Directory /usr/ftproot opened. Showing file list...

三、配置FTP自动启动

为了确保FTP服务在系统启动时自动启动,可以使用以下命令启用FTP服务的自启动功能:

sudo systemctl enable vsftpd

修改完成后,保存修改并使用以下命令重启FTP服务:

sudo systemctl restart vsftpd

相关推荐
Ruiery3 小时前
Linux 6.6内核 CPU 深度解析(七):调度器启动 — 从单核到多核,调度器分阶段点亮
linux·运维·服务器
50万马克的面包3 小时前
CSDN-栈队列数组-知识点整理
linux·运维·服务器
MicrosoftCloud3 小时前
用户权限 04|/etc/sudoers 安全配置:从最小授权到「别把 ALL 随便给人」
运维·安全·ubuntu·sudo·sudoers
wjkjpcba4 小时前
PCBA烧录程序是什么:PCBA包工包料厂家解析烧录与测试
linux·数据库·人工智能·smt贴片加工·pcba贴片加工厂
꯭自꯭闭꯭4 小时前
达梦事物特性及MVCC
linux·运维·数据库
91刘仁德5 小时前
HTTP协议详解:从URL到HTTP服务器的完整实战
服务器·网络·笔记·网络协议·http
亚川楼宇自控系统数据中心厂家6 小时前
实验室智能化管理系统|人环物智一体化管控平台
运维
羔羊++6 小时前
18_实验十七_其他命令与自定义启动变量
linux
zmsup7 小时前
Agent 上下文调优:结合 OpsArk 运维智能体,设计模型每一步真正需要的信息
运维·agent·上下文压缩·运维智能体·上下文调优
DYWorker0018 小时前
Linux驱动:RK3568 GMAC + YT8531C 千兆以太网全流程解剖
linux