Linux FTP服务问题排查

一、问题描述

最近linux虚拟机重启之后发现,FTP服务总是不正常,工具无法连接。

二、排查及处理过程

1、检查ftp服务是否正常安装:yes

rpm -qa|grep vsftpd

2、检查ftp服务是否正常启动:

systemctl status vsftpd

启动vsftpd

systemctl start vsftpd

3、使用连接工具测试

MobaXterm FTP连接不成功,提示:

<<< 530 Please login with USER and PASS.

Error EElFTPSUnacceptedReplyError: Unaccepted server reply code 530 to command PWD

错误代码530通常表示用户没有登录或者登录失败,服务器因为权限问题拒绝了用户的登录请求。

原因:root用户没有配置ftp对应的路径和权限。

更改root用户登录成功:

Opening FTP connection to 192.168.146.130

FTP login with username ftpuser

<<< 220 (vsFTPd 3.0.2)

>>> USER ftpuser

<<< 331 Please specify the password.

>>> PASS ***********

<<< 230 Login successful.

>>> FEAT

<<< 250 Directory successfully changed.

>>> PWD

<<< 257 "/usr/ftproot"

>>> CWD /usr/ftproot

<<< 250 Directory successfully changed.

>>> PWD

<<< 257 "/usr/ftproot"

Opening directory /usr/ftproot...

>>> PWD

<<< 257 "/usr/ftproot"

>>> CWD /usr/ftproot

<<< 250 Directory successfully changed.

>>> TYPE A

<<< 200 Switching to ASCII mode.

>>> PASV

<<< 227 Entering Passive Mode (192,168,146,130,207,32).

>>> LIST

<<< 150 Here comes the directory listing.

<<< 226 Directory send OK.

>>> CWD /usr/ftproot

<<< 250 Directory successfully changed.

Directory /usr/ftproot opened. Showing file list...

三、配置FTP自动启动

为了确保FTP服务在系统启动时自动启动,可以使用以下命令启用FTP服务的自启动功能:

sudo systemctl enable vsftpd

修改完成后,保存修改并使用以下命令重启FTP服务:

sudo systemctl restart vsftpd

相关推荐
M78佐菲1 小时前
ARM学习笔记(1)
linux·arm开发·笔记·嵌入式硬件·学习
骇客野人1 小时前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
益达丫3 小时前
Socket编程揭秘:端口、IP与进程通信的底层逻辑
linux·笔记
比兔代理3 小时前
正向代理与反向代理技术辨析,为什么代理 IP 属于正向代理
服务器·网络·http·ip
Wang's Blog4 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog4 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
蓝速科技5 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
Ivanqhz5 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
chicheese5 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky5 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu