解决【WVP服务+ZLMediaKit媒体服务】加入海康摄像头后,能发现设备,播放/点播失败,提示推流超时!

环境介绍

每人搭建的环境不一样,情况不一样,但是原因都是下面几种:

  1. wvp配置不当
  2. 网络端口未放开
  3. 网络不通

我搭建的环境:

WVP服务:windows下,用idea运行的源码

ZLM服务:虚拟机里

问题描述

复制代码
1.国标设备里能发现海康的摄像头,心跳正常
2.WVP服务与ZLM服务心跳正常
3.播放失败,推流超时

解决问题,我是第三种情况(详见下面的点播流程图的第5步)

原因是ZLM服务在虚拟机里,虚拟机默认是NAT网络连接方式,需要改为桥接模式,需要选择跟WVP和设备头一样网段的网卡

附上官网的点播流程图:https://doc.wvp-pro.cn/#/_content/theory/play

相关推荐
阿俊-全栈开发4 小时前
LikeShop 单商户SaaS商城分销模块二开:佣金计算与结算逻辑实现
java·开发语言·微服务·likeshop·likeshop开源商城·likeshop多商户
夜听莺儿鸣7 小时前
502-002_Linux驱动开发模块化编程
linux·驱动开发·模块化编程
wuminyu7 小时前
C++协程实现接收端的零拷贝Buffer管理原理剖析
java·linux·c语言·jvm·c++
硬件学长森哥8 小时前
成像技术实例-HDR视频技术基础
图像处理·音视频
科力锐品牌君8 小时前
应用级灾备 | 海量非结构化数据如何实现高效数据保护
linux·运维·网络·安全·系统安全·数据安全·灾备
zhangrelay8 小时前
ROS项目设计案例智能大模型正经乱答案例
linux·笔记·学习·ubuntu·机器人
流浪0019 小时前
Linux系统篇39——线程(四) pthread库的由来和线程的创建与等待
linux·操作系统·线程·pthread库
Lancker9 小时前
chnroute-linux — 中国大陆 IP 段每日自动更新 + 「仅允许国内访问」落地
linux·运维·tcp/ip
蜗牛互联网10 小时前
WSL Containers GA:本地AI容器的生命周期、网络与治理验收
java·网络·人工智能·后端
高山有多高10 小时前
【Linux笔记】Linux进程与守护进程
linux