解决docker目录内存不足扩容处理

当我们使用docker时,经常会创建新镜像和新容器,在新容器中又会安装各种包,这些东西不是虚拟的,而是实实在在存于我们的磁盘中,默认在/var/lib/docker中,这个目录是属于系统盘的,而系统盘的空间往往不大,这样就会造成,随着时间的推移,docker越来越大,最后系统盘的空间被占满,所以这个时候就需要迁移docker的存储目录到更大的盘,才能把系统盘的空间腾出来。

当重启容器提示no space left 就是内存不足

1、查看服务器所有磁盘的使用情况:

bash 复制代码
df -h

可以看到每个盘的大小,这里可以看到/dev/mapper/centos-root总大小是50G(相对其他盘小太多),之前docker给占满了,因为我后面给docker相关迁移到了home下面,所以空出很大的空间,可以看到/dev/mapper/centos-home空间总大小984G,挂载点是/home,于是我给docker相关的目录迁移到/home下了

2、查看docker镜像和容器存储目录的空间大小

bash 复制代码
du -sh /var/lib/docker/

3、停止docker服务

bash 复制代码
systemctl stop docker

停止失败的时候可以更换命令试试

bash 复制代码
service docker stop

4、docker目录不足迁移扩容方法:

  1. 将docker迁移到大容量的磁盘中

    我这里是迁移到/home/docker目录下,相当于给原来的/var换成了/home/docker其他的结构和之前保持一致

    bash 复制代码
    # 首先创建目录
    mkdir -p /home/docker/lib/
    #迁移
    rsync -avz /var/lib/docker /home/docker/lib/
  2. 编辑/etc/docker/daemon.json,添加参数,将docker的目录迁移绑定

    红框是添加的参数,nginx版本不同data-root可能会不生效,可以给data-root换成graph试试

  3. 重载和重启docker服务

    bash 复制代码
    systemctl daemon-reload && systemctl restart docker

    如果systemctl依然运行失败,可以使用以下命令重启docker试试:

    bash 复制代码
    service docker restart

    检查docker是否绑定新目录

    bash 复制代码
    docker info

    如果Docker Root Dir由/var/lib/docker变为你指定的目录,说明迁移成功

    删除docker旧目录

    bash 复制代码
    rm -rf /var/lib/docker

    这个时候再去使用docker image 、 docker ps 就可以发现之前的镜像和容器数据都在,并且可以正常使用啦

相关推荐
虎头金猫3 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS3 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站3 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏4 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心4 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing4 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅4 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)4 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang4 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren4 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github