linux StarRocks 安装

一、检查服务器是否支持avx2,如果执行命令显示空,则不支持,那么安装后无法启动BE

bash 复制代码
cat /proc/cpuinfo |grep avx2

我的支持显示如下:

二、安装

bash 复制代码
docker run -p 9030:9030 -p 8030:8030 -p 8040:8040 -p 9001:9000 --privileged=true -itd --name starrocks-test landnow/starrocks-test:v2.4.0
#浏览器输入:http://192.168.31.135:8030/  用户名:root 密码:空

docker ps
docker exec -it ce7d8c5c53c3 /bin/bash
mysql -h 127.0.0.1 -P9030 -uroot
#进入Docker查看FE信息
SHOW PROC '/frontends'\G
#进入Docker查看BE信息
SHOW PROC '/backends'\G

创建表:

sql 复制代码
create table orders (
    dt date NOT NULL,
    order_id bigint NOT NULL,
    user_id int NOT NULL
   
) PRIMARY KEY (dt, order_id)
PARTITION BY RANGE(`dt`) (
    PARTITION p20240922 VALUES [('2021-10-01'), ('2026-10-01'))
) DISTRIBUTED BY HASH(order_id) BUCKETS 4
PROPERTIES("replication_num" = "1",
"enable_persistent_index" = "true");

insert into orders values('2024-08-20',3,3)
select * from orders;

建表等使用navicat 操作时会报错,说明不是完全兼容mysql

相关推荐
XiaoMaqqqq20 分钟前
市面上正规的IP驱动产业新场景新工具哪家强
运维·python·网络协议·tcp/ip
huainingning1 小时前
RJ SW Console口忘记密码处理方法
linux·运维·服务器
布裘1 小时前
【银河麒麟】桌面系统循环登录,无法进入桌面?
linux·运维·服务器
慧都小项1 小时前
程序到了Linux才出错?用CLion把调试接到目标环境
linux·运维·服务器
Lsetea2 小时前
OpenSSL verify报unhandled critical extension:error 34与关键扩展排查
运维·https·ssl证书·openssl·证书链
guo_wen_qiang2 小时前
docker的备份与迁移
运维·docker·容器
Ruiery3 小时前
Linux 6.6内核内存管理深度解析(一):物理内存初始化 — memblock 怎么把内存交给 buddy
linux·运维·服务器
2401_868534783 小时前
无线网络规划设计
服务器·网络
库拉镜像AI牛牛4 小时前
短剧内容自动化生产:知漫剧工作室落地教程
大数据·服务器·前端·人工智能·语音识别
天蓝蓝的本我4 小时前
conda日常用到的命令积累1-登录linux,安装pycharm
linux·pycharm·conda