linux StarRocks 安装

一、检查服务器是否支持avx2,如果执行命令显示空,则不支持,那么安装后无法启动BE

bash 复制代码
cat /proc/cpuinfo |grep avx2

我的支持显示如下:

二、安装

bash 复制代码
docker run -p 9030:9030 -p 8030:8030 -p 8040:8040 -p 9001:9000 --privileged=true -itd --name starrocks-test landnow/starrocks-test:v2.4.0
#浏览器输入:http://192.168.31.135:8030/  用户名:root 密码:空

docker ps
docker exec -it ce7d8c5c53c3 /bin/bash
mysql -h 127.0.0.1 -P9030 -uroot
#进入Docker查看FE信息
SHOW PROC '/frontends'\G
#进入Docker查看BE信息
SHOW PROC '/backends'\G

创建表:

sql 复制代码
create table orders (
    dt date NOT NULL,
    order_id bigint NOT NULL,
    user_id int NOT NULL
   
) PRIMARY KEY (dt, order_id)
PARTITION BY RANGE(`dt`) (
    PARTITION p20240922 VALUES [('2021-10-01'), ('2026-10-01'))
) DISTRIBUTED BY HASH(order_id) BUCKETS 4
PROPERTIES("replication_num" = "1",
"enable_persistent_index" = "true");

insert into orders values('2024-08-20',3,3)
select * from orders;

建表等使用navicat 操作时会报错,说明不是完全兼容mysql

相关推荐
夜之眷属8 小时前
服务器被挖矿病毒入侵的排查与清理实录
运维·服务器
LoneEon8 小时前
CentOS7 部署 Nacos3.x 集群实战:从注册中心到 AI 管理中心
linux·人工智能·nacos
极客先躯8 小时前
高级java每日一道面试题-2026年01月20日-实战篇[Docker]-如何实现镜像的跨区域复制?
java·运维·docker·容器·架构图
传人8 小时前
为什么 Xshell 中可以通过java -version查询到java 版本号码,Electerm 却查不到?
java·linux·服务器
韩振方8 小时前
为什么服务显示占了 8G,实际内存却没那么多?
运维
陌上花开缓缓归以9 小时前
mebdlts3.4.1安全启动全流程
服务器·算法
鬼手点金9 小时前
opencode-全能开发者配置
java·linux·服务器·前端·javascript·学习·前向传播
xixiaoyunya9 小时前
虚拟机备份怎么做:镜像级与文件级搭配的完整实操方案
linux·运维·网络
墨家句子9 小时前
服务器被反复尝试登录之后:fail2ban 加密钥登录的五道加固
linux·后端
阿明69 小时前
进程替换【Linux】
linux·运维·服务器