[运维]5.镜像本地存在但仍然从网络拉取的问题

在deployment.yaml中设置image 为k8s.io/tomcat:8.5-jdk8,且这个镜像在本地存在:

复制代码
[root@node1 tmp]# ctr -n k8s.io images list | grep tomcat
docker.io/kubeguide/tomcat-app:v1                                                                                                                                            application/vnd.docker.distribution.manifest.v2+json      sha256:f2c465e01647be9a35c914205dc58912130e915426559cb60a7d12e9f4cc455e 352.5 MiB linux/amd64                                                                  io.cri-                               
k8s.io/tomcat:8.5-jdk8                                                                                                                                                       application/vnd.docker.distribution.manifest.v2+json      sha256:67f6f1f8e51fa8fdceb056c5b889b887ab8e00094e33fa981e35344511e937aa 151.6 MiB linux/amd64                                                                  io.cri-containerd.image=manag    

但是在创建pod的过程中仍然从远处拉取,造成pod启动失败:

复制代码
Events:
  Type     Reason     Age               From               Message
  ----     ------     ----              ----               -------
  Normal   Scheduled  30s               default-scheduler  Successfully assigned default/tomcat-749d98df56-hmlt9 to node1
  Normal   Pulled     2s (x5 over 29s)  kubelet            Container image "k8s.io/tomcat:8.5-jdk8" already present on machine
  Warning  Failed     2s (x5 over 29s)  kubelet            Error: failed to get image from containerd "sha256:6113f55245f6bb372e59de99ee3e9d848eef0bf64a07fcaf80e015f60ae8db08": image "docker.io/library/tomcat:8.5-jdk8": not found

解决方法:

发现这个问题和K8S的工作方式有关,Kubernetes 默认使用 docker.io/library/ 作为镜像仓库的前缀。如果您 Deployment 或 Pod 的 image 中只写了 tomcat:8.5-jdk8 或 docker.io/tomcat:8.5-jdk8,Kubernetes 实际上会自动补全为 docker.io/library/tomcat:8.5-jdk8。

所以将本地镜像的名称通过tag改为docker.io/library/tomcat:8.5-jdk8:

复制代码
ctr -n k8s.io images tag docker.io/tomcat:8.5-jdk8 docker.io/library/tomcat:8.5-jdk8

并将deployment中的镜像名称改为以上名称,则pod创建成功。

相关推荐
优化Henry16 分钟前
LTE 载波频率与频点配置详解
运维·网络·学习·5g·信息与通信
代码方舟43 分钟前
数据科学风控实战:基于天远全能消金报告构建自动化信用评估网关
运维·人工智能·自动化
科力锐品牌君1 小时前
应用级灾备 | 海量非结构化数据如何实现高效数据保护
linux·运维·网络·安全·系统安全·数据安全·灾备
KaiwuDB1 小时前
KaiwuDB 运维实战04:DRBD + KaiwuDB——物联网场景下的低成本数据库高可用方案
运维·数据库·物联网·时序数据库·kaiwudb·aiot·多模数据库
福建佰胜张工2 小时前
A5E00839230西门子工业核心配件详解:参数、安装调试与故障运维全攻略
运维·网络·安全·自动化
Lancker2 小时前
chnroute-linux — 中国大陆 IP 段每日自动更新 + 「仅允许国内访问」落地
linux·运维·tcp/ip
天远Date Lab2 小时前
零信任架构实战:基于天远全能消金报告(标准版)构建自动化骑手资信评估网关
运维·人工智能·架构·自动化
赛博守夜人2 小时前
反舞弊系列之二十一:数据驱动型反舞弊体系搭建,如何利用ERP与财务数据构建“异常交易自动化风控看板”?
运维·自动化
天衍四九-3 小时前
Docker容器实战系列(八):Docker生产最佳实践与避坑指南,系列终章
运维·docker·容器
大侠归来3 小时前
Ubuntu 搭建 APUE 环境:从源码编译到第一个示例跑通
linux·运维·ubuntu