记录一次docker报错无法访问文件夹,权限错误问题

记录一次docker报错无法访问文件夹,权限错误问题

1. 背景

  1. 使用docker安装photoview,为其分配了一个cache目录,用户其缓存数据。
  2. 在运行过程中,扫描文件后显示如下错误

could not make album image cache directory: mkdir /app/cache

  1. 检查映射的目录,其目录下无任何文件,符合报错内容即无法正确访问文件夹。
  2. 官方github的解答为:

Make sure that your media library's root folder and all the files and

subfolders are readable and searchable by other users: run the next

command (or corresponding sequence of commands from the ):Makefile

make readable If command(s) return error, run them under the user,

owning corresponding files and folders. Alternatively, run them adding

before the command: this will switch the execution context to user and

ask for the root password. You have to have permission to run in the

system.Permission deniedsudo rootsudo

If you don't want to give required permissions to group for your

files, alternatively, you can:others

create a group on your host with GID=999 and make all the files and

folders inside volumes of the service being owned by this group; then

set the appropriate permissions to the section.photoviewgroup create

on your host a group with GID=999 and a user in this group with

UID=999; then change the ownership of all the files and folders inside

volumes of the service to this user; then set the appropriate

permissions to the section.photoviewuser If you configured other

mounts with media files from other locations on the host (like

HOST_PHOTOVIEW_MEDIA_FAMILY or anything else), you need to run the

same commands, as in the target, for each media root folder on your

host manually: copy each command to your shell and replace the

variable with the absolute path to an additional media root folder

without the trailing . Run both commands for each additional root

folder.Makefilereadable/

  1. 官方的方式太复杂了,显示需要创建用户组并将对应的文件夹加入用户组,我不希望这么麻烦。

2. 解决

  1. 主要原因是文件夹的权限,默认是root,将其修改权限,为所有用户可以访问即可。
  2. 如果通过自己的compose安装,默认就是777的权限,但通过unraid进行安装,权限就不是这个。
  3. 修改对应文件夹的权限
cpp 复制代码
chmod -R 777 /mnt/user/appdata/photoview
  1. 修改后重启docker即可正常运行了
相关推荐
虎头金猫1 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS1 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站1 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏1 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心2 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing2 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅2 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)2 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang2 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren2 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github