记录一次docker报错无法访问文件夹,权限错误问题

记录一次docker报错无法访问文件夹,权限错误问题

1. 背景

  1. 使用docker安装photoview,为其分配了一个cache目录,用户其缓存数据。
  2. 在运行过程中,扫描文件后显示如下错误

could not make album image cache directory: mkdir /app/cache

  1. 检查映射的目录,其目录下无任何文件,符合报错内容即无法正确访问文件夹。
  2. 官方github的解答为:

Make sure that your media library's root folder and all the files and

subfolders are readable and searchable by other users: run the next

command (or corresponding sequence of commands from the ):Makefile

make readable If command(s) return error, run them under the user,

owning corresponding files and folders. Alternatively, run them adding

before the command: this will switch the execution context to user and

ask for the root password. You have to have permission to run in the

system.Permission deniedsudo rootsudo

If you don't want to give required permissions to group for your

files, alternatively, you can:others

create a group on your host with GID=999 and make all the files and

folders inside volumes of the service being owned by this group; then

set the appropriate permissions to the section.photoviewgroup create

on your host a group with GID=999 and a user in this group with

UID=999; then change the ownership of all the files and folders inside

volumes of the service to this user; then set the appropriate

permissions to the section.photoviewuser If you configured other

mounts with media files from other locations on the host (like

HOST_PHOTOVIEW_MEDIA_FAMILY or anything else), you need to run the

same commands, as in the target, for each media root folder on your

host manually: copy each command to your shell and replace the

variable with the absolute path to an additional media root folder

without the trailing . Run both commands for each additional root

folder.Makefilereadable/

  1. 官方的方式太复杂了,显示需要创建用户组并将对应的文件夹加入用户组,我不希望这么麻烦。

2. 解决

  1. 主要原因是文件夹的权限,默认是root,将其修改权限,为所有用户可以访问即可。
  2. 如果通过自己的compose安装,默认就是777的权限,但通过unraid进行安装,权限就不是这个。
  3. 修改对应文件夹的权限
cpp 复制代码
chmod -R 777 /mnt/user/appdata/photoview
  1. 修改后重启docker即可正常运行了
相关推荐
阳光九叶草LXGZXJ3 小时前
达梦数据库-报错-15-列【XXX】长度超出定义
linux·运维·数据库·sql·学习
黄大刀4 小时前
DataPulse一款开箱即用的SCADA(四)-历史记录
运维·scada·动环
归秋1426 小时前
2026 企业 AI 办公工具选型指南:从评估框架到产品适配
大数据·运维·人工智能
Android系统攻城狮6 小时前
Linux Gstreamer深度解析之gst_audio_encoder_set_frame_max调用流程与实战(六十一)
android·linux·运维·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
硅基手札8 小时前
【Linux内核专栏 14】网络协议栈
linux·运维·网络协议
工作10年+,存储芯片行业10 小时前
Linux NVMe 中断排查与性能优化:CPU 亲和性
linux·运维·服务器·windows·性能优化·ssd·pcie
快乐の番薯10 小时前
卷王问卷考试系统自动化功能测试
运维·功能测试·自动化
一号弯11 小时前
装完LINUX,请先新建日常用户
linux·运维·服务器
许彰午11 小时前
03-Linux环境准备依赖包内核参数与用户组
linux·运维·服务器·数据库
阳光九叶草LXGZXJ12 小时前
达梦数据库-报错-16-MERGE INTO提示:无效的列名[XX]
linux·运维·数据库·sql·学习