docker compose一键部署容器监控 CAdvisor+InfluxDB+Granfana

docker compose一键部署容器监控 CAdvisor+InfluxDB+Granfana

CAdvisor监控收集+InfluxDB存储数据+Granfana展示图表

1、原生命令

通过docker stats 命令可以查看当前宿主机上所有创建的容器的CPU,内存和网络流量等信息

复制代码
docker stats 

缺点:只能查看当前宿主机的全部容器,而且查询是实时的、不能存储、没有指标预警等功能。

2、CAdvisor

CAdvisor 是谷歌公司用来分析运行中的 docker 容器的资源占用以及性能特性的工具。

CAdvisor是一个容器资源监控工具,包括容器的内存,CPU,网络IO,磁盘IO等监控,同时提供了一个WEB页面用于查看容器的实时运行状态。

CAdvisor提供了很多数据集成接口,支持InfluxDB,Redis,Kafka,Elasticsearch等集成,可以加上对应配置将监控数据发往这些数据库存储起来。

CAdvisor功能主要有两点:

1、展示Host和容器两个层次的监控数据。

2、展示历史变化数据。

3、InfluxDB

InfluxDB是用Go语言编写的一个开源分布式时序、事件和指标数据库,无需外部依赖。

为了持久化存储数据和统一收集展示监控数据,需要将CAdvisor的数据存储到InfluxDB中。

InfluxDB是一个时序数据库,专门用于存储时序相关数据,很适合存储CAdvisor的数据。而且,CAdvisor本身已经提供了InfluxDB的集成方法,丰启动容器时指定配置即可。

InfluxDB主要功能:

1、基于时间序列,支持与时间有关的相关函数(如最大、最小、求和等);

2、可度量性:你可以实时对大量数据进行计算;

3、基于事件:它支持任意的事件数据;

4、Granfana

Grafana是一个开源的数据监控分析可视化平台,支持多种数据源配置(支持的数据源包括InfluxDB, MySQL,Elasticsearch, OpenTSDB、Graphite等)和丰富的插件及模板功能,支持图表权限控制和报警Grafan主要特性。

Grafana主要功能:

1、 灵活丰富的图形化选项

2、可以混合多种风格

3、支持白天和夜间模式

4、可配置多个数据源

5、创建目录

复制代码
mkdir /data/cAdvison/ -p && cd /data/cAdvison/

6、创建docker-compose.yml文件

复制代码
version: '2' 
  
services: 
 influxdb: 
  image: tutum/influxdb
  restart: always 
  ports: 
    - "8083:8083" 
    - "8086:8086" 
  environment: 
    - PRE_CREATE_DB=cadvisor 
  volumes: 
    - ./influxdb:/data 
  
 cadvisor: 
  image: google/cadvisor 
  links: 
    - influxdb:influxsrv 
  command: -storage_driver=influxdb -storage_driver_db=cadvisor -storage_driver_host=influxsrv:8086 
  restart: always 
  ports: 
    - "8080:8080" 
  volumes: 
    - /:/rootfs:ro 
    - /var/run:/var/run:rw 
    - /sys:/sys:ro 
    - /var/lib/docker/:/var/lib/docker:rw
  
 grafana: 
  image: grafana/grafana 
  restart: always 
  links: 
    - influxdb:influxsrv 
  ports: 
    - "3000:3000" 
  environment: 
    - HTTP_USER=admin 
    - HTTP_PASS=admin 
    - INFLUXDB_HOST=influxsrv 
    - INFLUXDB_PORT=8086 
    - INFLUXDB_NAME=cadvisor 
    - INFLUXDB_USER=root 
    - INFLUXDB_PASS=root 
  volumes: 
    - ./grafana:/var/lib/grafana:rw

7、启动docker compose

复制代码
docker compose  up -d

8、查看服务状态

复制代码
docker compose ps

9、grafana服务启动失败排查

1) 检查grafana服务日志
复制代码
docker compose logs -f grafana
2) 日志提示没有权限,给目录授权
复制代码
chmod -R  777 ./grafana/
3) 重启grafana服务
复制代码
docker compose restart grafana
4) grafana服务恢复正常

10、访问各服务页面

1) cAdvisor
2) InfluxDB

InfluxDB的Web管理平台

3) Granana

Grafana管理控制页面

默认账号密码

admin/admin



相关推荐
云栖梦泽13 分钟前
Linux内存管理
linux·运维·服务器
吴声子夜歌18 分钟前
Nginx应用与运维——Nginx Web服务应用实战(静态文件服务器的搭建)
运维·前端·nginx
海宇服务32 分钟前
零信任架构实战:基于海宇身份证OCR构建自动化自助终端核验网关
运维·人工智能·架构·自动化
ken22321 小时前
ubuntu 24.04, audacity 4 AppImage 加载 libavdevice.so.62 /.61 /.63 失败:依赖缺失?
linux·运维·ubuntu
wzq11_6661 小时前
Kubernetes集群——命令篇
云原生·容器·kubernetes
未完成的歌~1 小时前
Windows 系统镜像备份还原 操作手册
运维
阳光九叶草LXGZXJ1 小时前
达梦数据库-学习-69-DM9主备集群部署
linux·运维·服务器·数据库·sql·学习
Sun 32851 小时前
Linux 常用命令梳理
linux·运维·服务器·开发·常用命令
ai小陈1 小时前
深度学习CUDA异步报错定位:从错误堆栈到最小复现
运维·人工智能·深度学习·ai·gpu算力
Chill601 小时前
服务器home文件夹太小怎么把配置迁移到其他盘
运维·服务器