【环境搭建】远程服务器搭建ElasticSearch

参考:

非常详细的阿里云服务器安装ElasticSearch过程..._阿里云服务器使用elasticsearch-CSDN博客

服务器平台:AutoDL

注意:

1、切换为非root用户,su 新用户名,否则ES无法启动

2、安装过程中没有出现设置账号密码,但请求时需要鉴权,可以关闭鉴权配置。

config-> elasticsearch.yml-> xpack.security.enabled false

创建索引:

复制代码
curl -X PUT "http://localhost:9200/docs" -H "Content-Type: application/json" -d '
{
  "mappings": {
    "properties": {
      "content": {
        "type": "text"
      }
    }
  }
}'

插入数据:

复制代码
curl -X POST "http://localhost:9200/docs/_doc" -H "Content-Type: application/json" -d '
{
  "content": "干完这个活就出门遛弯"
}'

通过python创建es对象,并且进行bm25检索

python 复制代码
from elasticsearch import Elasticsearch

self.es_client = Elasticsearch("http://127.0.0.1:9200")

dsl = {
            'query': {
                'match': {
                    'content': "想出门遛弯"
                }
            },
            "size": 3
        }

search_result = self.es_client.search(index='docs', body=dsl)

本地kibana怎么连接远程ES

以AutoDL为例

注意:本地kibana和远程服务器上的ES版本号要一致

AutoDL提供的SS H通道。host:127.0.0.1,port: 6006

STEP 1 修改ES的config->elasticresearch.yml, host和port配置

STEP2 修改kibama的config->kibana.yml, 修改对应的es host信息

STEP 3 服务器启动ES,./bin/elasticsearch, 本地启动kibana ./bin/kibana

注意kibana config中server port , 浏览器打开http:localhost:5602

相关推荐
Wang's Blog31 分钟前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog33 分钟前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
蓝速科技1 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
Ivanqhz1 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
chicheese1 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky2 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南3 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123453 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人3 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender3 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理