【2024.10.10练习】Emergency

题目描述

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1​ and C2​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​, c2​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​ to C2​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1​ and C2​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题目分析

本题涉及最短路径问题,考虑使用Dijkstra算法贪心解决。使用数组cost[MAX_N]存储起点到每个顶点的最短路径,再使用第二个记忆化数组maxr[MAX_N]存储起点到每个顶点最短路径下的最多救援队数。

此外,要求的第一个输出为最短路径数量,由于读错了英文题干,一开始输出的是最短路径长度导致错误。求最短路径数量也只需在dijkstra基础上修改即可。


我的代码

注意最短路径数的递推关系,如果最短路径更新了,则该结点的最短路径数=通向它的结点的最短路径数;如果最短路径相同,则给该结点的最短路径数+=通向它的结点的最短路径数。

实际上必须要在当前路径最短的前提下更新最多救援数才能获得正确答案。

cpp 复制代码
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAX_N = 500; //0~N-1城市数
int n;	//城市
int m;	//道路
int c_1;	//起点
int c_2;	//终点
int rescue[MAX_N];	//救援队数
int L[MAX_N][MAX_N]; //边长
int cost[MAX_N]; //最短路径
bool marked[MAX_N]; //是否已确定
int maxr[MAX_N]; //最多救援
int pathnum[MAX_N]; //到i的最短路径数

void dijkstra(int a, int b) {
	//更新起点信息
	cost[a] = 0;
	maxr[a] = rescue[a];
	pathnum[a] = 1;
	bool rest = 1;

	while (rest) {
		//寻找当前最小距离未被选择结点
		int minverge;
		int mincost = 0x3f3f3f3f;
		for (int i = 0; i < n; i++)
		{
			if (marked[i] == 0 && cost[i]<mincost) {
				minverge = i;
				mincost = cost[i];
			}
		}
		marked[minverge] = 1;
		//更新相邻结点最短距离
		for (int i = 0; i < n; i++)
		{
			if (marked[i] == 0 && cost[i] >= cost[minverge] + L[minverge][i]) {
				//确定最短路径数
				if (cost[i] == cost[minverge] + L[minverge][i]) {
					pathnum[i] += pathnum[minverge];
				}
				else {
					pathnum[i] = pathnum[minverge];
				}
				//确定最短路径和最多救援
				cost[i] = cost[minverge] + L[minverge][i];
				maxr[i] = max(maxr[minverge] + rescue[i], maxr[i]);
			}
		}
		//检查是否还有结点未确定
		rest = 0;
		for (int i = 0; i < n; i++)
		{
			if (marked[i] == 0) {
				rest = 1;
			}
		}
	}
	//输出结果
	cout<< pathnum[b] <<" "<< maxr[b];
}

int main() {
	//Input
	cin >> n >> m >> c_1 >> c_2;
	for (int i = 0; i < n; i++)
	{
		cin >> rescue[i];
		cost[i] = 0x3f3f3f3f;
	}
	for (int i = 0; i < n; i++)
	{
		for (int j = 0; j < n; j++)
		{
			L[i][j] = 0x3f3f3f3f;
		}
	}
	int a, b;
	for (int i = 0; i < m; i++)
	{
		cin >> a >> b;
		cin>> L[a][b];
		L[b][a] = L[a][b];
	}

	//Shrotest Path
	dijkstra(c_1, c_2);
	return 0;
}
相关推荐
Sheep Shaun几秒前
希尔排序和直接插入排序
c语言·数据结构·算法·排序算法
小林熬夜学编程24 分钟前
【Linux系统编程】第三十弹---软硬链接与动静态库的深入探索
服务器·c语言·开发语言·前端·c++·算法
2401_8572979132 分钟前
招联金融校招内推2025
java·前端·算法·金融·求职招聘
夜喵YM1 小时前
[YM]模板-归并排序
java·数据结构·c++·算法·排序算法
修炼室1 小时前
掌握寻找峰值元素的高效算法:从线性遍历到二分查找
数据结构·算法
2401_877158731 小时前
Serial 与 Parallel GC 之间的不同之处?
java·jvm·算法
冉佳驹1 小时前
数据结构 ——— 单链表oj题:相交链表(链表的共节点)
c语言·数据结构·算法·链表
橘飞侠1 小时前
熵权法计算评价指标权重——使用Excel VBA实现
人工智能·算法·机器学习
IronmanJay1 小时前
【LeetCode每日一题】——679.24 点游戏
数据结构·算法·leetcode·回溯·递归·679.24 点游戏·24点游戏