docker login 命令登录harbor镜像仓库(含报错)

作者:程序那点事儿 日期:2024/02/02 14:10


执行登录命令:docker login -uadmin 192.168.43.106:8880

报错:

Error response from daemon: Get "https://192.168.43.106:8880/v2/": http: server gave HTTP response to HTTPS client

原因是我们docker client使用的是https,而我们搭建的Harbor私库用的是http的,所以会有这样的报错,导致访问不了。

解决办法: vim /etc/docker/daemon.json

"insecure-registries":"192.168.43.106:8880", # 添加docker信任地址

systemctl daemon-reload

systemctl restart docker

注意:出现如下报错大概率是地址写错了!###

Error response from daemon: Get "http://192.168.43.105:8880/v2/": Get "http://192.168.3.106:8880/service/token?account=admin&client_id=docker&offline_token=true&service=harbor-registry": dial tcp 192.168.3.106:8880: i/o timeout

是ip地址写错了,坑爹呀!

docker-compose down -v

./prepare

docker-compose up -d

相关推荐
虎头金猫2 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS2 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站2 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏2 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心2 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing2 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅2 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)2 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang2 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren2 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github