isis 不同区域的配置实验

一、同区域下,Level-1、Level-2、Level-1-2 之间的拓扑计算:

1、拓扑1:

2、配置:

复制代码
[R2]:
isis 1
 is-level level-2
 cost-style wide
 network-entity 49.0001.0000.0000.0002.00
 is-name R2
#
interface GigabitEthernet0/0/1
 ip address 10.1.24.2 255.255.255.0 
 isis enable 1
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255 
 isis enable 1
#

[R3]:
isis 1
 is-level level-2
 cost-style wide
 network-entity 49.0001.0000.0000.0003.00
 is-name R3
#
interface GigabitEthernet0/0/2
 ip address 10.1.34.3 255.255.255.0 
 isis enable 1
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.255 
 isis enable 1
#

[R4]:
isis 1
 cost-style wide
 network-entity 49.0001.0000.0000.0004.00
 is-name R4
#
interface Serial4/0/0
 link-protocol ppp
 ip address 10.1.45.4 255.255.255.0 
 isis enable 1
#
interface GigabitEthernet0/0/0
 ip address 10.1.24.4 255.255.255.0 
 isis enable 1
#
interface GigabitEthernet0/0/2
 ip address 10.1.34.4 255.255.255.0 
 isis enable 1
#
interface LoopBack0
 ip address 10.1.4.4 255.255.255.255 
#

[R5]:
isis 1
 is-level level-1
 cost-style wide
 network-entity 49.0001.0000.0000.0005.00
 is-name R5
#
firewall zone Local
 priority 15
#
interface Serial4/0/0
 link-protocol ppp
 remote address 10.1.45.4 
 ip address 10.1.45.5 255.255.255.0 
 isis enable 1
#
interface LoopBack0
 ip address 5.5.5.5 255.255.255.255 
 isis enable 1
#

3、结论:

同区域下,Level-1-2(相当于 OSPF 的 ABR/ASBR) 会把 Level-1 的明细路由向 Level-2 泄露,但不会把 Level-2 的路由向 Level-1 泄露;Level-2 路由器可以通过 Level-1-2 路由器访问 Level-1 的业务,但 Level-1 无法访问 Level-2 的业务

可以看到:R2、R3 上有 R5 的明细路由,但 R5 没有 R2、R3 的路由

二、不同区域下,Level-1、Level-2、Level-1-2 之间的拓扑计算:

1、拓扑2:

2、配置:我们仅把拓扑 1 的 R3、R4 的区域改为 49.0002

3、结论:如果 Level-1-2 发现连接有其他区域的 Level-2 邻居,会向 Level-1 区域下发 ATT置位的 LSP,同时向 Level-1 产生一条路径最优的默认路由

三、不同区域下,仅允许/不允许 Level-1 访问某个外部 Level-2 路由器

1、配置:

1)Level-2 区域的 R2、R3 isis 进程下分别打 tag 2、tag 3

2)Level-1-2 区域的 R4 下发 ATT 永不置位的命令;写 route-policy,匹配允许/不允许的 tag,把 Level-2 强行泄露给 Level-1,同时将出方向的 lsp 做 route-policy 过滤

复制代码
[R2]:
isis 1
 circuit default-tag 2
#

[R3]:
isis 1
 circuit default-tag 2
#
dis isis lsdb verbose level-2
#

[R4]:
route-policy filterR3 deny node 10 
 if-match tag 3
route-policy filterR3 permit node 20 
#
isis 1
 filter-policy route-policy filterR3 export 
 import-route isis level-2 into level-1 filter-policy route-policy filterR3
 attached-bit advertise never 
#

到 R2 上查看 Level-2 收入的 LSP,看到已经打上 tag

在 R5 上查看:因为 R4 永不下发 ATT 置位的 LSP,R4 把发给 R5 的 LSP 的 ATT 置为 0,删除默认路由;以路由策略强行泄露 Level-2 的明细路由给 Level-1,其中,Down-Bit-Set 置位1,则 L1/2 发给 L2 的 TLV128/135 LSP 不会再计算路由,防止路由回灌

四、isis 和 ospf 的区别:

isis 和 ospf 最大的不同就是:ospf 是以链路关系来计算拓扑,但 isis 是以节点的角色定位来计算拓扑;ospf 同个路由器接口可以加入不同区域,但 isis 只能有一个角色;ospf 可以计算多种网络拓扑场景:p2p、ma、p2mp、nbma,但isis只有两种:p2p 和 ma,所以,ospf 适合复杂型的拓扑计算,但 isis 的TLV 的扩展性强,v4 和 v6 可以共用同一进程、同个拓扑,能容纳更多的参数,所以更适合扩展性强的拓扑场景。

ospf 的 ma 拓扑建立过程中选举 DR/BDR,不支持抢占,但isis 的 ma 仅有一个 dis,支持抢占;isis 可以配置 3 个实体名,可以在割接或者其他状况下,建多个邻居,不会因邻居协议down的情况下,导致流量中断

相关推荐
小羊Linux客栈32 分钟前
自动化:批量文件重命名
运维·人工智能·python·自动化·游戏程序
伤不起bb1 小时前
MySQL 高可用
linux·运维·数据库·mysql·安全·高可用
shykevin3 小时前
python开发Streamable HTTP MCP应用
开发语言·网络·python·网络协议·http
whgjjim4 小时前
docker迅雷自定义端口号、登录用户名密码
运维·docker·容器
tmacfrank5 小时前
网络编程中的直接内存与零拷贝
java·linux·网络
数据与人工智能律师6 小时前
虚拟主播肖像权保护,数字时代的法律博弈
大数据·网络·人工智能·算法·区块链
瀚高PG实验室7 小时前
连接指定数据库时提示not currently accepting connections
运维·数据库
QQ2740287567 小时前
Soundness Gitpod 部署教程
linux·运维·服务器·前端·chrome·web3
淡忘_cx7 小时前
【frp XTCP 穿透配置教程
运维
南方以南_7 小时前
Ubuntu操作合集
linux·运维·ubuntu