docker环境装gitlab遇到的几个问题

1.运行起gitlab容器后总是间歇性的报出502、500等错误页面,,根本无法正常使用

解决:经过查看日志发现总是报writing value to /dev/shm/gitlab/puma/gauge_all_puma_14-0.db failed with unmapped file"这个错误,去容器中df -h查看/dev/shm的大小只有64m,发现这个存储是满的,没空间了,导致报错。在容器启动命令中加入 --shm-size=1g 解决,当然这里的容量大小可以根据实际情况去设置

2.gitlab上的项目克隆地址中没有端口信息,地址是错的

解决:是因为gitlab默认的是80端口,所以默认项目克隆地址没加端口。

第一步:进入到容器内部

第二步:修改/opt/gitlab/embedded/service/gitlab-rails/config/gitlab.yml中的gitlab:port为实际的端口

第三步:容器内执行:gitlab-ctl restart

3.使用tortoisegit在用户名密码都对的情况下老是报认证失败

解决:换一个老版本的tortoisegit客户端,很可能是tortoisegit和git的版本不适配导致的

4.gitlab的默认用户名密码的问题

装好了之后,不知道用什么用户名密码登录。默认用户名是root,密码需要修改。

1.gitlab-rails console -e production

2.user = User.where(id: 1).first

3.user.password = '新密码'

4.user.password_confirmation = '新密码'

5.user.save!

相关推荐
九皇叔叔1 天前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s
程序猿小郑2 天前
Docker Compose 构建完整服务实战指南:从入门到最佳实践
docker·容器
行百里er2 天前
5 分钟跑起 Redis(Docker 版)
redis·后端·docker
Mr.朱鹏2 天前
Docker三剑客实战指南:Docker、Dockerfile 和 Docker Compose
python·docker·devops·dockerfile
鬼先生_sir2 天前
Docker 完整教程
docker
java_logo2 天前
Docker 一键部署 Jellyfin:快速搭建私有化媒体服务器
docker·私有化部署·jellyfin·硬件加速·媒体服务器·轩辕镜像·影音库
jianpeng的工程笔记2 天前
WeKnora 搭建研发 EDA 知识库:Docker 部署、RAG 与 Wiki 实践
docker·知识库·eda·rag
ZeroNews内网穿透2 天前
内网部署 Halo 建站,用 ZeroNews 免费内网穿透安全发布到公网(无公网 IP 也能 HTTPS 访问)
docker·https·内网穿透·nas·反向代理·halo·zeronews
九皇叔叔2 天前
K8S 资源菜单
docker·容器·kubernetes·k8s
wdfk_prog2 天前
ROS教程08:从 TransportTCP::connect() 追到 TCPROS Connection Header、序列化与 Socket 数据传输
运维·缓存·docker·容器·ros