Elasticsearch 安装教程:驾驭数据海洋的星际导航仪

目录

  • 一、准备工作
    • [1. ES的下载](#1. ES的下载)
  • 二、安装步骤
  • 三、注意事项
  • 四、启动报错
    • [1. org.elasticsearch.bootstrap.StartupException: java.lang.RuntimeException: can not run elasticsearch as root](#1. org.elasticsearch.bootstrap.StartupException: java.lang.RuntimeException: can not run elasticsearch as root)
    • [2. max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144](#2. max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144])

种一棵树最好的时间是10年前,其次就是现在,加油!
--by蜡笔小柯南

ES在Linux平台的安装教程,接下来,跟随我的脚步,一起去安装吧!

一、准备工作

1. ES的下载

  1. 进入ES官网下载地址,ES官网下载地址
  2. 选择合适的Linux平台,进行下载,点击 Linux x86_64 按钮,等待下载完成

二、安装步骤

  1. 将下载好的elasticsearch压缩包上传到服务器

  2. 选择合适的目录进行解压,我们一般选择放在 opt目录下,所以,在解压时,指定具体的解压目录

    shell 复制代码
    # 进入opt目录
    cd /opt
    
    # 创建一个空文件夹,名为es
    mkdir es
    
    # -C /opt 表示解压到 /opt 目录下
    tar -zxvf elasticsearch-7.17.25-linux-x86_64.tar.gz -C /opt/es
  3. 解压完成后,进入opt下的es目录,查看解压后的文件

    shell 复制代码
    cd /opt/es
    ll
  4. 目录及含义

    目录 含义
    bin 可执行脚本目录
    config 配置文件
    jdk 内置jdk目录
    lib 类库
    logs 日志目录
    modules 模块目录
    plugins 插件目录
  5. 进入es的安装目录,新建一个data文件夹

    shell 复制代码
    cd /opt/es/elasticsearch-7.17.25
    
    mkdir data
  6. 修改es配置文件,elasticsearch.yml

    shell 复制代码
    # 进入config目录
    cd /opt/es/elasticsearch-7.17.25/config
    
    # 编辑配置文件
    vim elasticsearch.yml
  7. 配置内容如下:

    shell 复制代码
    # 有一些默认的配置,我们只需要取消前面的注释即可
    # 也可以根据自己的配置,修改对应的名称
    
    cluster.name: my-application
    node.name: node-1
    
    # 这是数据文件目录,即第5步创建的
    path.data: /opt/es/elasticsearch-7.17.25/data
    
    # 日志文件目录
    path.logs: /opt/es/elasticsearch-7.17.25/logs
    
    network.host: 0.0.0.0
    http.port: 9200
    
    # 和node.name的名称保持一致
    cluster.initial_master_nodes: ["node-1"]
    
    xpack.security.enabled: false
  8. 创建新用户,因为 elasticsearch 不允许使用 root 用户启动,如果使用 root 用户启动,则会报错:can not run elasticsearch as root,解决方法:can not run elasticsearch as root

    shell 复制代码
    # 创建一个名为es的用户,用户名可以自定义,这里以es为例
    adduser es
    
    # 查看是否创建成功
    id es

    显示上面信息表示创建成功

  9. 为es用户设置密码

    shell 复制代码
    # 为es用户设置密码
    passwd es

    输入密码后按回车确认。注意:在Linux中,输入密码后不在终端上显示,光标不会动,实际上已经输入了,确保两次输入的密码一致就可以。其余的不用输入,一直回车,最后输入y,回车

  10. 给新创建的es用户授予文件的权限,/opt/es/elasticsearch-7.17.25/ 是es的安装目录

    shell 复制代码
    chown -R es:es /opt/es/elasticsearch-7.17.25/
  11. 切换用户,输入设置的密码进行切换

    shell 复制代码
    su es
  12. 进入es的bin目录下,启动测试

    shell 复制代码
    cd /opt/es/elasticsearch-7.17.25/bin
    
    ./elasticsearch
  13. 云服务器,确保在控制台中,开放了9200端口,通过 http://ip地址:9200/ 访问,显示如下信息则说明成功

三、注意事项

以 ./elasticsearch启动后,关闭控制台时,服务会自动关闭,可以使用另一种方式,以后台的方式启动

shell 复制代码
./elasticsearch -d

四、启动报错

1. org.elasticsearch.bootstrap.StartupException: java.lang.RuntimeException: can not run elasticsearch as root

解决方法:can not run elasticsearch as root

2. max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144

解决方法:max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144

如果你有任何疑问或经验分享,可以在评论区留言哦~~

不管在任何时候,我希望你永远不要害怕挑战,不要畏惧失败。每一个错误都是向成功迈出的一步,每一个挑战都是成长的机会,因为每一次的努力,都会使我们离梦想更近一点。只要你行动起来,任何时候都不算晚。最后,把座右铭送给大家:种一棵树最好的时间是10年前,其次就是现在,加油!共勉 💪。
快来吧 👇👇👇

不论是Java的基础资料,还是那些看似枯燥实则精妙的八股文,这里都有你意想不到的解读方式,让复杂变简单,让枯燥变有趣~

相关推荐
liulilittle15 分钟前
短期内不存在通用 AI 工作流魔法
大数据·开发语言·c++·人工智能·llm·agent·tools
光影少年1 小时前
langchain与langgraph区别以及学习路线
elasticsearch·langchain·llm
计算机源码社1 小时前
基于Spark的租房数据挖掘与可视化平台构建研究 基于K-Means与PCA的租房价值洞察与可视化分析
大数据·hadoop·数据挖掘·spark·毕业设计·kmeans·课程设计
康实训1 小时前
2026职业院校家政实训室整体建设方案
大数据·人工智能·实训室·实训室建设
一隅论数智1 小时前
给AI Agent一颗“私域大脑“:本体增强的工程化之路
大数据·运维·数据仓库·人工智能·笔记·学习·政务
龙腾AI白云1 小时前
【轻量化大模型:低成本AI落地的产业新范式】
大数据·数据库·人工智能·机器学习
计算机编程指导师1 小时前
【计算机毕设选题】基于Hadoop的电信网络诈骗话术语义特征挖掘分析系统源码 毕业设计 选题推荐 毕设选题 数据分析 机器学习
大数据·数据库·python
W***25921 小时前
2026企业AI办公工具选型全指南
大数据·人工智能
IT古董1 小时前
《FDE前沿部署工程师实战教程》31 - Enterprise AI Reliability:Agent稳定性与生产运维体系
大数据·数据库·人工智能
troy1282 小时前
金融财务系统 Reference Data Asset 构建指南:从模型设计到落地实践
大数据·金融·区块链