【nginx】client timed out和send_timeout的大小设置

websocket连接会断开,抓包检查后发现是中间的代理服务器nginx断开的,同时将后端和浏览器都断开了。将nginx日志调到debug级别后,有下面的断开信息。

bash 复制代码
[info] 125923#125923: *34 client timed out (110: Connection timed out) while proxying upgraded connection, client: 127.0.0.1, server: , request: 

检查nginx.conf的配置,proxy_send_timeout和proxy_read_timeout都设置得非常大,而且抓包也没有长时间没有流量。网上找不到和分析上面的报错,自己动手分析。由于我们的错误是在测试环境稳定复现的,有很好的分析条件。

首先,将nginx日志调到debug级别后,日志能看到的是info,没有真正开启debug。找了下要用带debug编译的nginx才可以。折腾了一会系统方面的配置得到真正的debug日志。

接下来是日志分析。在info日志前有10000的timer(下图是5000的示意)。然后就在nginx的conf文件里面找和10相关的配置,找到了一个send_timeout 10;。高度相关。

最后,我们修改这个参数的大小验证和日志的关联性。修改为5,日志就是上图打印的样子。修改为15则等了一两小时没有断开。可见 client timed out和send_timeout的大小设置有关系。

网上关于send_timeout的解释没法准确的理解,试图通过抓包给出准确的解释,无奈发现nginx和浏览器,以及nginx和后端最后通信间隔都是一样的,没有给出准确的解释。

多了点耐心做详尽的分析,抓包下来看到的现象是这样的,nginx最后转发给后端服务的时间间隔了5s,然后nginx首先断开也是和后端的连接,猜测是nginx给后端发数据间隔了5s导致。但本质上为什么nginx会间隔5s才给后端发包,因为浏览器的包到nginx先间隔了5s,然后nginx转发的时候就差了5s。结论是上行请求方向的数据差了5s导致的。

进一步测试,配置改成7s出现到后端的连接断开8s后才断开到浏览器的连接,显然线索已经很清晰,这次的断开是因为nginx在7s内没有给后端发消息,nginx主动断开。

相关推荐
虎头金猫14 小时前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
还是大剑师兰特14 小时前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
只睡四小时15 小时前
Canvas 弹道联机实战:700 行 + 固定时间步长
python·websocket·html5·游戏开发·canvas
AI职业加油站16 小时前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏16 小时前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
xing-xing17 小时前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅17 小时前
linux(8) 软硬链接
linux·运维·服务器
张洛闻Eren17 小时前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
其实防守也摸鱼18 小时前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透
布裘18 小时前
【银河麒麟】V4桌面图标消失,右击鼠标没反应排查
运维·银河麒麟·桌面环境