阿里云服务器手动搭建WordPress【官方文档&注意事项】

这是官方文档

注意事项

  1. 先配LNMP,我的上一篇文章

  2. 到这里发现,没有基于ubuntu的教程,所以创建服务器时选择centos

  3. 在官方文档第四步"下载WordPress,并移动至网站根目录"中,首先它让cd /usr/share/nginx/html,如果没有这个路径,一定是LNMP没弄对,请回到上一篇重新做,不要自作聪明mkdir出来(我在说我自己 +_+)。

  4. 在官方文档第六步"修改Nginx配置文件"中,sudo vim /etc/nginx/nginx.conf,打开文件后发现没有server。所以我将文档上的图片(下图)抄了下来。location php那一部分应该眼熟。注意,图片中的第一行文字要注释掉,否则会出现本文第8条的现象。

    server {
    listen 80;
    listen [::]:80;
    server_name _;
    root /usr/share/nginx/html/wordpress;

    复制代码
     # Load configuration files for the default server block.
     include /etc/nginx/default.d/*.conf;
    
     location / {
     	index index.php index.html index.htm;
     }
    
     location ~ .php$ {
     	root /usr/share/nginx/html/wordpress;
     	fastcgi_pass 127.0.0.1:9000;
     	fastcgi_index index.php;
     	fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
     	include fastcgi_params;
     }
    
     error_page 404 /404.html;
     location = /404.html {
     }
    
     error_page 500 502 503 504 /50x.html;
     location = /50x.html {
     }

    }

  5. 这里有一个小技巧,sudo nginx -t 可以检查配置文件是否正确,如果有错能给出出哪行语法错误(比如它提示了我大括号不匹配,最后发现少打一个分号)。直到无误后会有一个successful。

  6. 如果出现以下欢迎界面(Welcome to nginx! If you see this page),即将成功。注释掉配置文件的一行内容
    就是下面这个# include /etc/nginx/conf.d/*.conf;

结果:

注册登录后:

相关推荐
鹿邑妈糊9 小时前
kvm-clock时钟虚拟化原理
云计算
辻弋20110 小时前
【无标题】
大数据·服务器·前端·搜索引擎·开源软件
北京中科新远科技13 小时前
AI网卡五层检查法:协议、PCIe、NUMA、端口与验收
服务器·网络·人工智能
shdkfbbv13 小时前
【无标题】
linux·运维·服务器
wp123_113 小时前
TLVR 电感在 AI 服务器电源中的应用与市场前景分析
服务器·人工智能·科技·ai·硬件工程
ycvv15 小时前
手机启动失败后的数据提取评估:系统状态、加密条件与文件验收
服务器·数据库·智能手机
_upupup15 小时前
包管理器和vim
linux·服务器
一颗小树x15 小时前
NVIDIA 驱动故障排查实录:内核升级导致 nvidia-smi 失效
linux·服务器·nvidia驱动·启动失败·内核升级
DianSan_ERP15 小时前
多平台订单自动下载与回传的技术实现:从消息推送到状态闭环引言
java·linux·服务器·前端·网络·架构·自动化
流星。。方15 小时前
网站做好了怎么上线?从域名解析到访问验证的完整实操
服务器