istio配置重复的svc报错

现象:

两个vs中配置了同一个svc地址,导致其中的一个vs路由配置不生效,看到istiod服务的报错duplicate domain from service

解决:

istiod服务报错日志

bash 复制代码
2024-11-13T14:54:50.394181675+08:00     "pilot_vservice_dup_domain": {
2024-11-13T14:54:50.394188065+08:00         "xxx.svc.cluster.local:80": {
2024-11-13T14:54:50.394192825+08:00             "proxy": "xx-59cf68bfdf-x57d2.xx-ns",
2024-11-13T14:54:50.394197005+08:00             "message": "duplicate domain from service: xxx-api.xx-master.svc.cluster.local:80"
2024-11-13T14:54:50.394200645+08:00         }
2024-11-13T14:54:50.394204055+08:00     }
2024-11-13T14:54:50.394207575+08:00 }

配合istioctl的其它子命令进行验证

bash 复制代码
# 查看侦听器配置
istioctl proxy-config listeners xxx-pod.xx-ns |grep "xx"
10.99.46.36    80    Trans: raw_buffer; App: http/1.1,h2c                                     Route: x.x-master.svc.cluster.local:80
10.99.46.36    80    ALL                                                                      Cluster: outbound|80||mp-x.ns.svc.cluster.local
# 查看集群cluster配置
istioctl proxy-config clusters xx-pod.ns |grep "xx"
xx.ns.svc.cluster.local                           80        -          outbound      EDS              
xx.ns.svc.cluster.local                         80        -          outbound      EDS     
# 路由配置
istioctl proxy-config routes xx-pod.ns |grep -E "tts"
deploymentxx.ns.svc.cluster.local:80                 deploymentxx.ns.svc.cluster.local:80                              *                                                                                                                     /*                     svc1-name-virtualservice.ns
deploymentxx.ns.svc.cluster.local:80               deploymentxx.ns.svc.cluster.local:80                            *                                                                                                                     /*                     svc1-name-virtualservice.ns
80                                                                                    deploymentxx.ns.svc.cluster.local:80                              svc1-name, svc1-name.ns + 1 more...                           /*                     svc2-virtualservice.ns
80                                                                                    deploymentxx.ns.svc.cluster.local:80                            svc2, svc2.ns + 1 more...                       /*                    svc-virtualservice.ns

将其中一个vs的hosts字段更改即可

此篇属于事后记录

相关推荐
贾斯汀frank3 天前
Spring Boot + K8s + Istio 与 Spring Cloud:微服务治理能力对比
spring cloud·微服务·istio
Eminem893 天前
14、k8s持久化存储
k8s
上火的金鱼妹5 天前
higress网关访问+ 模型访问的安全策略管控
k8s·higress·ai网关
weixin_444579306 天前
Containerd
容器·k8s
Dragon_qu·x7 天前
MongoDB 高可用集群部署
运维·数据库·mongodb·k8s·helm
此冬歌咏14 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心14 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
流烟默14 天前
K8s StatefulSet 详解:有状态应用的“身份证”与“固定住址”
k8s·statefulset
cg.family14 天前
K8S集群手动巡检
k8s
九皇叔叔15 天前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s