coredns报错plugin/forward: no nameservers found

coredns报错plugin/forward: no nameservers found并且pod无法启动

出现该报错原因 是coredns获取不到宿主机配置的dns地址

查看宿主机是否有dns地址

resolvectl status

我这里是配置正确后,如果没配置过以下是不会显示出dns地址的

给宿主机增加静态dns地址之后将coredns的pod删除重启 即正常

相关推荐
红姐跨境书19 分钟前
如何利用AI提升YouTube内容创作与运营效率
网络
别动我齐刘海28 分钟前
简历技术栈全面复习——UDP / TCP / CAN / ZMQ / Protobuf 通信工程
网络·c++·python·tcp/ip·机器学习·udp·github
Zhou14113636 分钟前
Docker_03_DockerCompose多容器编排
运维·docker·容器
北京中科新远科技38 分钟前
AI网卡五层检查法:协议、PCIe、NUMA、端口与验收
服务器·网络·人工智能
shdkfbbv38 分钟前
【无标题】
linux·运维·服务器
周洲08301 小时前
STM32片内Flash读写深度详解|掉电参数保存、底层原理
linux·前端·stm32
数字供应链安全产品选型2 小时前
智能体与代码安全一体化选型指南:跳出功能清单,以运行时硬指标衡量真实防护能力
网络·人工智能
shimly1234562 小时前
比 find + grep 更好用的 nm + addr2line
linux
迷途之人不知返2 小时前
【进程控制】-3-进程等待
linux
_upupup2 小时前
包管理器和vim
linux·服务器