wsl2上mysql出现ip端口冲突问题

现象出现于win11系统wsl2平台跑ubuntu,在win11 22h2之后提供固化wsl ip地址的功能,具体可以百度,大概是在C:/用户/用户名文件夹下新建.wslconfig文件,其中添加固化IP地址的参数。

固化完毕后,wsl将不再使用虚拟ip,而是和主机共用IP,这时候如果wsl、win同时安装的mysql数据库服务器,那么就会出现wsl、win两个mysql端口冲突的问题,比如我在固化wsl ip后,wsl平台上无法启动mysql服务,提示33060端口冲突(win平台mysql的3306端口被我手动修改,所以不冲突)

所以在固化wsl ip之后,要么把mysql开放端口进行修改全部错开,要么只保留一边的mysql服务。

相关推荐
꯭自꯭闭꯭3 小时前
DM7主备升级方案
linux·服务器·数据库
Zelman3 小时前
TCP 协议
网络协议·tcp/ip
蜗牛互联网3 小时前
MongoDB Atlas Agent Engine之后,如何用版本门禁防止陈旧写入
java·数据库·人工智能·后端·mongodb
IvorySQL4 小时前
PostgreSQL 日报 |PostgreSQL 19 Beta 4 发布(9 月 25 日)
数据库·postgresql
科技研学社4 小时前
绿色合规时代,碳足迹与ESG倒逼服装工厂工序升级
数据库·人工智能
赵渝强老师5 小时前
【赵渝强老师】崖山数据库的数据库文件
数据库·国产数据库·yashandb·崖山数据库
做运维的阿瑞5 小时前
多表查询基础:INNER JOIN、LEFT JOIN、RIGHT JOIN
数据库·sql·mysql·算法
life码农5 小时前
Nginx 配置允许指定 IP 段访问:从 192.168.1.1 到 192.168.1.124 及 /24 详解
网络·tcp/ip·nginx
javaDocker5 小时前
16.5 小时,我打掉了两只「SSL 握手失败」的怪
网络·网络协议·ssl
IvorySQL5 小时前
PostgreSQL 日报 | 可见性映射数据损坏修复(9 月 26 日)
数据库·postgresql