wsl2上mysql出现ip端口冲突问题

现象出现于win11系统wsl2平台跑ubuntu,在win11 22h2之后提供固化wsl ip地址的功能,具体可以百度,大概是在C:/用户/用户名文件夹下新建.wslconfig文件,其中添加固化IP地址的参数。

固化完毕后,wsl将不再使用虚拟ip,而是和主机共用IP,这时候如果wsl、win同时安装的mysql数据库服务器,那么就会出现wsl、win两个mysql端口冲突的问题,比如我在固化wsl ip后,wsl平台上无法启动mysql服务,提示33060端口冲突(win平台mysql的3306端口被我手动修改,所以不冲突)

所以在固化wsl ip之后,要么把mysql开放端口进行修改全部错开,要么只保留一边的mysql服务。

相关推荐
阳光九叶草LXGZXJ3 小时前
达梦数据库-报错-15-列【XXX】长度超出定义
linux·运维·数据库·sql·学习
字节渡客4 小时前
Redis键明明过期了,业务还在读到旧数据
数据库·redis·spring
OnlineProxy6 小时前
亚马逊多账号运营:如何在规避“关联封号”风险的同时实现电商规模化扩张
服务器·数据库·redis
盟接之桥6 小时前
当大模型遇见线束制造:不是通用AI,而是行业AI
大数据·网络·人工智能·安全·制造
91刘仁德7 小时前
IP协议详解:从IP协议头到网段划分、路由与NAT
linux·服务器·网络·网络协议·tcp/ip
辻弋2017 小时前
五年前的旅行视频糊成马赛克?Video2X用Real-ESRGAN逐帧重建细节,但只支持Windows、集显用户建议直接放弃
服务器·数据库·windows·游戏引擎·电脑
可乐鸡翅yeah_8 小时前
业务中 M3U8 水印相关坑,硬水印和动态水印区别
前端·网络·数据库·ffmpeg·m3u8在线
石头麻辣鱼9 小时前
Bamboo 调度系统 OceanBase 适配实战:存储过程迁移踩过的三个大坑
数据库
龙亘川9 小时前
数智驱动民政升级 精准守护民生保障
大数据·数据库·人工智能
念何架构之路9 小时前
zap扩展生态与总结
java·前端·数据库