wsl2上mysql出现ip端口冲突问题

现象出现于win11系统wsl2平台跑ubuntu,在win11 22h2之后提供固化wsl ip地址的功能,具体可以百度,大概是在C:/用户/用户名文件夹下新建.wslconfig文件,其中添加固化IP地址的参数。

固化完毕后,wsl将不再使用虚拟ip,而是和主机共用IP,这时候如果wsl、win同时安装的mysql数据库服务器,那么就会出现wsl、win两个mysql端口冲突的问题,比如我在固化wsl ip后,wsl平台上无法启动mysql服务,提示33060端口冲突(win平台mysql的3306端口被我手动修改,所以不冲突)

所以在固化wsl ip之后,要么把mysql开放端口进行修改全部错开,要么只保留一边的mysql服务。

相关推荐
starzy199013 小时前
Flink Sliding Window 详解及代码实现:从窗口重叠到状态爆炸防控
运维·数据库·flink
万联WANFLOW13 小时前
网络排障:如何从延迟、丢包、带宽定位海外访问异常
网络·架构·业界资讯
jnrjian13 小时前
DRG-50857 ORA-30576 drixmd.PurgeKGL CTXSYS
数据库·oracle
zzzyyy53813 小时前
TCP 协议学习笔记:从报文格式到异常处理
linux·网络
心易行者14 小时前
Python在线运行+SQLite数据库实战:0成本搭个人数据后台,5个场景直接套用
前端·网络·人工智能·python
志栋智能14 小时前
集成是关键:让巡检超自动化融入现有工具链
运维·服务器·数据库·架构·自动化
IvorySQL14 小时前
PostgreSQL 日报|逻辑解码竞态条件修复(9 月 20 日)
数据库·人工智能·postgresql
终端安全笔记14 小时前
iOS 27 之后「策略空转」:设备升级不报错,但旧策略不再管它
android·网络·安全·ios·智能手机
星恒讯工业路由器14 小时前
配电DTU新国标落地:硬件加密成硬门槛,选型逻辑正在改变
网络·物联网·智能路由器·工业路由器·新国标·硬件加密·配电dtu
鹿鸣天涯14 小时前
护网专项工作 | 勒索病毒防护指南
网络·计算机网络·安全