Windows server 2016 无法部署docker问题

根据流程winserver16安装docker ee,发现服务器管理器的添加角色和功能-功能中没有 container

根据流程winserver16安装docker desktop,发现安装 hyper-v 报错

原因:

本人测试用windows server 2016使用vmware搭建 ,而vmware本身可能不支持嵌套虚拟化 。

若想支持hyper-v等(以安装docker),需对虚拟机进行如下勾选配置:

勾选后启动虚拟机将报错:

选择是,则提示:

总结:由于不支持嵌套虚拟化,在vm虚拟机中可能无法再次安装用于虚拟的功能。这可能与主机的计算机配置、主机和虚拟机的软件和系统版本等有关。

相关推荐
百事牛科技8 小时前
WinRAR注释功能:给压缩包留个便签
windows·winrar
筝筝ba9 小时前
openBMC功耗封顶GUI测试
服务器
sukalot9 小时前
Windows 驱动实例分析系列:libwdi 驱动分析 - examples 篇(一)
windows·驱动开发
加载力科技10 小时前
硬盘咔咔响是坏盘信号!赶在数据丢失前克隆换盘:不重装系统、不丢文件
windows·嵌入式硬件·系统安全·策略模式·命令模式·硬盘
niuTaylor10 小时前
飞腾 FT-2000/4 Ubuntu 内存卡 / NVMe SSD 系统制作完整指南
linux·服务器·人工智能·驱动开发·单片机
无序的浪11 小时前
测试博客-基于微服务的在线判题系统
java·spring cloud·docker·微服务·测试·在线判题
Huangjin007_12 小时前
【Linux 系统篇(二十五)】文件(二) 系统文件I/O详解
linux·运维·服务器
2601_9623649712 小时前
电脑人脸解锁的安全基石,聊聊 Windows Hello 硬件规范
windows·安全·电脑
云表无代码开发12 小时前
日本开发者彻底破防:中文太强了!换成英文直接裂开
大数据·服务器·人工智能·microsoft·信息可视化
LBL122013 小时前
内网容器部署FTP日志监控服务
运维·服务器·容器