【MySQL常见疑难杂症】常见文件及其所存储的信息

1、MySQL配置文件的读取顺序

(非Win)/etc/my.cnf、/etc/mysql/my.cnf、/usr/local/mysql/etc/my.cnf、~/.my.cnf

可以通过命令查看MySQL读取配置文件的顺序

bash 复制代码
[root@hadoop01 ~]# mysql --help |grep '/etc/my.cnf'
/etc/my.cnf /etc/mysql/my.cnf /usr/local/mysql/etc/my.cnf ~/.my.cnf 
[root@hadoop01 ~]# 

2、数据文件,以及文件作用

数据文件:.frm、.MYI、.MYD、.ibd、.ibdata*、.ib_logfile*、undo*、ibtmp1、auto.cnf、db.opt、.CSM、.CSV、.TRN、.TRG。

🦎.frm:表结构定义文件。

🦎.MYI:MyISAM存储引擎索引文件。

🦎.MYD:MyISAM存储引擎数据文件。

🦎.ibd:InnoDB存储引擎独立表空间文件。

🦎.ibdata*:InnoDB存储引擎共享表空间文件。

🦎.ib_logfile*:InnoDB存储引擎redo log文件。

🦎undo*:InnoDB存储引擎独立undo文件。

🦎ibtmp1:InnoDB存储引擎临时表空间文件。

🦎auto.cnf:用于存放MySQL实例的全局唯一的server-uuid的文件。

🦎db.opt:用于存放MySQL实例的schema级别的默认字符集和默认校对规则的文件。

🦎.CSM:用于存放CSV存储引擎的元数据等相关信息的文件。

🦎.CSV:用于存放CSV存储引擎的数据文件,每行数据的列值之间使用逗号分隔。

🦎.TRN:用于存放与触发器相关的元数据。

🦎.TRG:用于存放触发器定义语句以及与定义相关的信息。

日志文件:error.log(error log)​、localhost.log(generallog)​、mysql-bin.(binlog)​、mysql-relay-bin.(relay log)​、slow-query.log(slow log)​。

🦎error.log(error log)​:错误日志,记录着MySQL启动之后mysqld打印的相关信息。错误日志文件在MySQL Server启动之后必须存在;否则,在使用mysqld_safe启动数据库时会因为找不到错误日志文件而报错,终止启动过程(如果直接使用mysqld程序来启动数据库,则不会有这个问题,因为mysqld进程发现错误日志不存在时会重新创建)​。

🦎localhost.log(general log)​:一般查询日志,启用该日志之后,在MySQL Server中执行的所有SQL语句都会被记录。查询日志可以在MySQL Server启动之后动态开关、自动创建。

🦎mysql-bin.(binlog)​:二进制日志,用于复制架构中的数据同步(从库I/O线程从主库读取)​,MySQL Server中涉及数据变更的SQL语句都会被记录,可以指定单个文件的大小,写满指定大小的文件之后自动切换到一个新文件。
🦎mysql-relay-bin.
(relay log)​:中继日志,用于复制架构中的数据同步(从库I/O线程从主库读取binlog之后写入自身的中继日志中)​。

🦎slow-query.log(slow log)​:慢查询日志,SQL语句的执行时间超过指定时间,被认为执行缓慢,会被记录到该文件中。

其他文件:mysql.pid(pid)​、mysql.sock(socket)​、mysql.sock.lock(socket lock)​。

🦎 mysql.pid(pid):MySQL Server启动之后存放进程号的文件。

🦎 mysql.sock(socket):MySQL Server启动之后用于本地UNIXDomain通信的sock文件。

🦎 mysql.sock.lock(socket lock):MySQL Server启动之后用于锁定本地socket文件的锁标记文件。这是MySQL 5.7.x版本中新增的,如果MySQL Server非正常关闭,该文件可能残留而导致MySQL重新启动失败,删除该文件重新启动即可。

在MySQL 8.0中,数据字典库performance_schema、mysql、sys中的所有MyISAM存储引擎都改为使用InnoDB存储引擎,且所有的.frm文件也不见了,表结构文件和视图等定义信息都被放到了InnoDB存储引擎的数据字典表中,performance_schema数据字典表和mysql下的general_log、 slow_log表特殊,因为不支持事务,所以使用了新的.sdi后缀的文件来代替,该文件中记录的是JSON格式的表结构描述信息

bash 复制代码
tree /home/mysql/data/mysqldata1/* | grep -Eiv '.frm|.myi|.myd|.ibd'
相关推荐
CoLiuRs24 分钟前
电商价格是怎样算出来的
数据库·redis·缓存
小蒜学长28 分钟前
基于Python的动物救助站管理系统的设计与实现(代码+数据库+LW)
数据库·后端·python·django·动物救助
JAVA面经实录91735 分钟前
Java高级后端 · 全套面试通关手册(MySQL)
java·mysql·面试
weixin_404551241 小时前
自动化数据库理解:用 AI 与 LLM 自动推断表的用途与关系
数据库·人工智能·自动化
java1234_小锋1 小时前
【技术专题】Mysql8 数据库 - Mysql8 简介 & 安装以及配置
数据库·mysql
oradh1 小时前
Oracle固定执行计划的方法----SQL Profie(三)
数据库·sql·oracle
斯内普吖2 小时前
(开源)水果蔬菜商城实战指南 基于 Java + SSM + Vue + MySQL
java·vue.js·mysql·开源
测试学习test2 小时前
SPI读取W25Q64硬件驱动(HAL库)
数据库·stm32·嵌入式硬件·算法
做运维的阿瑞2 小时前
mysql数据库分组查询:GROUP BY 与 HAVING 的执行逻辑
数据库·sql·mysql
LaughingZhu3 小时前
Product Hunt 每日热榜 | 2026-10-01
数据库·人工智能·深度学习·神经网络·搜索引擎