< OS 有关 > Ubuntu 24 SSH 服务器更换端口 in jp/us VPSs

原因:

两台 VPS 的 ssh 端口一直被密码重试, us 这台已经封了 632, jp 这台两周前清过一次 sqlite3 数据,现在赞到 1008

Fail2Ban 是使用 sqlite3 来记录,数据量大后,硬盘的 I/O 会飙升,我有写过一个 app Project-33 来统计攻击并与地理位置匹配,但没有发 code,主要是没使用需求。

关联的文章:

当发现 计算机被 网络上的其它 IP 地址攻击 找谁?_22.41.46.66网络攻击-CSDN博客

< 自用文儿 > 下载 MaxMind GeoIP Databases 对攻击的 IP 做 地理分析_maxmind geoip 下载-CSDN博客

< OS 有关 > 阿里云 几个小时前 使用密钥替换 SSH 密码认证后, 发现主机正在被"攻击" 分析与应对 -CSDN博客

环境:

两台 VPS: JP、USW

操作系统:Ubuntu 24

APPs: ufw 只安装在 USW

被动修改 SSH 端口从 22->9922

1. 在东京的阿里云 jp

1) 修改配置文件

复制代码
sudo sed -i 's/^Port 22$/Port 9922/' /etc/ssh/sshd_config

2)在阿里防火墙开放端口 9922,并禁止 22

3)重启计算机

复制代码
sudo reboot

2. 在美国的 VPS:usw

1) 修改配置文件

复制代码
sudo sed -i 's/^Port 22$/Port 9922/' /etc/ssh/sshd_config

2)在 ufw 中配置

打开 9922 端口,禁用原 22 端口

复制代码
ufw allow 9922/tcp
ufw deny 22/tcp

查看 ufw,以确定修改成功

复制代码
sudo ufw status verbose

3)重启计算机

复制代码
sudo reboot

小结:

fail2ban 不需要修改,因为它的识别方法:filter=sshd

相关推荐
羔羊++2 小时前
18_实验十七_其他命令与自定义启动变量
linux
DYWorker0014 小时前
Linux驱动:RK3568 GMAC + YT8531C 千兆以太网全流程解剖
linux
lisanmengmeng5 小时前
NRPE 添加命令(一)
linux·运维·服务器
树下水月6 小时前
Typora破解
linux·服务器·前端
沫璃染墨7 小时前
《从零入门Linux系统篇(五十七):线程篇·十——生产者消费者模型进阶:从环形缓冲区到POSIX信号量》
linux·运维·服务器·开发语言·c++·系统架构·信号处理
wuminyu7 小时前
LockStack在虚拟线程Mount和Unmount拷贝过程剖析
java·linux·c语言·jvm·c++
深念Y7 小时前
rime-雾凇拼音-配置记录
linux·junit·软件·拼音·kde
殷色玫瑰8 小时前
C++ string类详解:常用接口、字符串操作与模拟实现
java·linux·c语言·开发语言·数据结构·c++
忆挽篱笙歌9 小时前
gcc,g++
linux
l1t9 小时前
修复WSL CreateInstance/E_UNEXPECTED和 mounted read-only 错误
linux·windows·wsl