MySQL启动报错解决

报错内容:

bash 复制代码
[root@k8s-node1 ~]# systemctl start mysqld
Job for mysqld.service failed because the control process exited with error code.
See "systemctl status mysqld.service" and "journalctl -xeu mysqld.service" for details.
[root@k8s-node1 ~]# journalctl -xe mysqld.service 
Failed to add match 'mysqld.service': Invalid argument
[root@k8s-node1 ~]# systemctl status mysqld
● mysqld.service - MySQL Server
     Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; vendor preset: disabled)
     Active: activating (auto-restart) (Result: exit-code) since Tue 2025-03-11 18:53:48 CST; 106ms ago
       Docs: man:mysqld(8)
             http://dev.mysql.com/doc/refman/en/using-systemd.html
    Process: 654160 ExecStartPre=/usr/bin/mysqld_pre_systemd (code=exited, status=0/SUCCESS)
    Process: 654199 ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/mysqld.pid $MYSQLD_OPTS (code=exited, status=1/FAILURE)

使用 journalctl 查看与 mysqld 相关的详细日志输出:

bash 复制代码
[root@k8s-node1 ~]# journalctl -xeu mysqld.service
░░ 
░░ A start job for unit mysqld.service has begun execution.
░░ 
░░ The job identifier is 395576.
Mar 11 18:54:36 k8s-node1 mysqld_pre_systemd[655044]: /usr/bin/mysqld_pre_systemd: line 48: 655064 Killed                  /usr/sbin/mysqld ${instance:+--defaults-group-suffix=@$instance} --initialize --datadir="$datadir" --user=mysql>
Mar 11 18:54:37 k8s-node1 mysqld[655067]: Initialization of mysqld failed: 0
Mar 11 18:54:37 k8s-node1 systemd[1]: mysqld.service: Control process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ An ExecStart= process belonging to unit mysqld.service has exited.
░░ 
░░ The process' exit code is 'exited' and its exit status is 1.
Mar 11 18:54:38 k8s-node1 systemd[1]: mysqld.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ The unit mysqld.service has entered the 'failed' state with result 'exit-code'.
Mar 11 18:54:38 k8s-node1 systemd[1]: Failed to start MySQL Server.
░░ Subject: A start job for unit mysqld.service has failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A start job for unit mysqld.service has finished with a failure.
░░ 
░░ The job identifier is 395576 and the job result is failed.
Mar 11 18:54:39 k8s-node1 systemd[1]: mysqld.service: Scheduled restart job, restart counter is at 6197.
░░ Subject: Automatic restarting of a unit has been scheduled
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ Automatic restarting of the unit mysqld.service has been scheduled, as the result for
░░ the configured Restart= setting for the unit.
Mar 11 18:54:39 k8s-node1 systemd[1]: Stopped MySQL Server.
░░ Subject: A stop job for unit mysqld.service has finished
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A stop job for unit mysqld.service has finished.
░░ 
░░ The job identifier is 395639 and the job result is done.
Mar 11 18:54:39 k8s-node1 systemd[1]: Starting MySQL Server...
░░ Subject: A start job for unit mysqld.service has begun execution
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A start job for unit mysqld.service has begun execution.

可以看出 mysqld 服务在启动过程中失败了,特别是在初始化阶段

解决方法:

bash 复制代码
[root@k8s-node1 ~]# systemctl stop mysqld
[root@k8s-node1 ~]# yum clean all
0 files removed
[root@k8s-node1 ~]# mv /var/lib/mysql /var/lib/mysql_backup
[root@k8s-node1 ~]# mkdir /var/lib/mysql
[root@k8s-node1 ~]# chown mysql:mysql /var/lib/mysql
[root@k8s-node1 ~]# mysqld --initialize --user=mysql --datadir=/var/lib/mysql
[root@k8s-node1 ~]# systemctl restart mysqld
相关推荐
仍然.27 分钟前
Redis---缓存
数据库·redis·缓存
Aloudata36 分钟前
LookML 语义模型 vs 企业级独立语义层:BI 建模语言能否承担企业语义底座?
数据库·人工智能·数据分析·数据资产·dataagent
程序员-Benothing38 分钟前
Vim编辑器从入门到精通:模式、快捷键、配置、插件
linux·运维·服务器
细嗅蔷薇@44 分钟前
排序和分⻚(order by 、limit)
数据库·oracle
m0_646429971 小时前
Docker 完整核心知识点总结(超通俗易懂版)
运维·docker·容器
wdfk_prog1 小时前
LWIP教程 09:从 `tcp_slowtmr()` 到 Fast Retransmit——TCP 超时重传与重复 ACK
服务器·网络·数据库·网络协议·tcp/ip
逸模1 小时前
BIM在连锁餐饮装修中的应用:不只是画三维图
大数据·数据库·人工智能·物联网·建模
梦想平凡1 小时前
棋牌游戏技术实战(五):从对局事件重新执行规则,核对棋盘和最终状态
数据库·游戏·oracle
亚川楼宇自控系统数据中心厂家1 小时前
IBMS 集成管理系统:如何打通楼宇自控实现建筑一体化管控
运维
白露与泡影1 小时前
Oracle AI Database 26ai RAC 部署步骤、关键命令与一键脚本
数据库·人工智能·oracle