Jmeter分布式测试启动

代理客户端配置

打开jmeter.properties文件,取消注释并设置端口(如server_port=1099),

并添加server.rmi.ssl.disable=true禁用SSL加密。

(Linux系统)修改jmeter-server文件中的RMI_HOST_DEF为代理机实际IP。

启动代理客户端

./jmeter-server

错误1:An error occurred: Cannot start. 10-60-41-84 is a loopback address

如果出现上面的错误,需要添加上本机ip地址启动:

./jmeter-server -Djava.rmi.server.hostname=192.168.1.156

或者修改jmeter-server中的参数:

上面的配置主要是为了解决服务器上多网卡的问题,让jmeter的客户端与代理服务器上面的客户端通信时,使用同一个网段。

错误2:

复制代码
Server failed to start: java.rmi.server.ExportException: Listen failed on port: 0; nested exception is: 
        java.io.FileNotFoundException: rmi_keystore.jks (No such file or directory)
An error occurred: Listen failed on port: 0; nested exception is: 
        java.io.FileNotFoundException: rmi_keystore.jks (No such file or directory)
ubuntu@10-60-41-84:/data/application/jmeter/apache-jmeter-5.6.3/bin$ 

修改配置,禁用ssl,server.rmi.ssl.disable=true

修改默认端口

jmeter-server的默认端口是1099,如果想修改为其它的端口,可以修改配置文件jmeter.properties

配置本地客户端,用于管理远程代理客户端

‌1. 指定代理机列表‌

复制代码
   修改jmeter.properties中的remote_hosts,格式为代理机IP:端口,多个地址用逗号分隔(如192.168.1.100:1099,192.168.1.101:1099)。

‌禁用SSL并启动测试‌

  1. 同样设置server.rmi.ssl.disable=true以避免连接错误。

  2. 通过GUI菜单选择"远程启动"或命令行执行jmeter -n -t <脚本> -r触发分布式测试。

相关推荐
冷凝娇2 小时前
【学习jmeter】ServeRest
jmeter
小师兄吃牛肉3 小时前
Java 同步系列之 ZooKeeper 分布式锁
java·分布式·java-zookeeper
糟了好像在长脑子4 小时前
面试总被问分布式ID? 十分钟带你读懂美团 Leaf 号段模式
分布式
zuozewei5 小时前
第00篇-为什么是-k6-AI-时代的工具选型
软件测试·jmeter·性能测试·ai测试·k6
qq_白羊座19 小时前
Jmeter 使用自增参数
jmeter
方方洛1 天前
ray教程-00-前言与导读
人工智能·分布式·机器学习
方方洛1 天前
ray教程-01-认识Ray
人工智能·分布式·机器学习
yexianglunbai1 天前
RabbitMQ 详解:从入门到实战
分布式·rabbitmq
此时不提桶,更待何时1 天前
06-16-B-Kafka面试与生产事故实战
分布式·面试·kafka
mesyinjinghan1 天前
半导体 MES 与 ERP 的接口边界:六类单据该留在哪一层
分布式·eap·半导体mes