【解决】自己的域名任何端口都访问不到,公网地址正常访问,服务器报错500。

一、问题描述

后端项目部署在服务器上,通过域名访问接口服务器报错500,通过浏览器访问殒命的任何端口都是无法访问此网站。

但是通过公网地址访问是可以正常访问到的,感觉是域名出现了问题

二、解决过程

先说结论:问题原因是,域名只映射了ipv4.但是电脑影射了ipv6。或者就是DNS解析错误。

打开阿里云域名管理查看记录类型正常

打开服务器查看安全策略配置正常

cmd运行如下命令, nslookup后为自己的域名

bash 复制代码
nslookup hvri1.xyz

可以强制使用8.8.8.8验证,,nslookup后为自己的域名

bash 复制代码
nslookup hvri1.xyz 8.8.8.8

所以确定了问题所在就好解决了

打开网络共享中心,选择当前网络,点击属性

1、第一步取消勾选Ipv6协议

2、ipv4配置如下

点击确定

测试是否解决


相关推荐
xh didida33 分钟前
Linux -- 基础IO
linux·服务器·开发语言·c++
心易行者1 小时前
Agent应用+API端点商业化进阶实战:从单体智能体到可付费调用的API全流程
运维·服务器·人工智能·python·apache
科技研学社1 小时前
精度决胜品质:羽绒服缝制工艺标准与自动化精度对标解析
运维·自动化
夜之眷属1 小时前
Core dump 崩溃排查:JVM 宕机后,那份 core 文件怎么用 gdb 还原现场
java·运维·服务器·jvm
Initialize293081 小时前
Redis 内存打满、连接数飙红?运维排查四步法
运维
zly35002 小时前
centos7 mount设备挂载 /dev/sda1/硬盘挂载
linux·运维·服务器
零基础1232 小时前
FinalShell 使用教程:从安装到高效运维
运维·经验分享·笔记·finalshell
帷幕落秋2 小时前
Docker的两种安装
运维·docker·容器
fengkai45452 小时前
十二、Redis -2
运维·数据库·redis·容器