To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C
- C Programming Language, M
- Mathematics (Calculus or Linear Algrbra), and E
- English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C
, M
, E
and A
- Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C
, M
and E
. Then there are M lines, each containing a student ID.
Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A
> C
> M
> E
. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A
.
Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A
核心题意:
给出学生数量和查询数量
输入学生学号和三门课的分数
对学生的单科排名以及平均分进行排名
查询时输出学生的最好一门科目以及排名
如学生不存在则输出'N/A'
JAVA存在运行超时情况
java
import java.util.*;
public class Main {
static class Student {
int id;
int[] grade = new int[4]; // grade[0]为平均分,grade[1-3]为CME成绩
public Student(int id, int c, int m, int e) {
this.id = id;
grade[1] = c;
grade[2] = m;
grade[3] = e;
// 修正:先转换为double再计算平均分,避免整数除法截断
grade[0] = (int) Math.round((c + m + e) / 3.0);
}
}
// 科目顺序:A(平均分)、C、M、E
static char[] course = {'A', 'C', 'M', 'E'};
static Map<Integer, int[]> rankMap = new HashMap<>(); // 存储每个学生的各科排名
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
int m = sc.nextInt();
Student[] students = new Student[n];
for (int i = 0; i < n; i++) {
int id = sc.nextInt();
int c = sc.nextInt();
int mScore = sc.nextInt();
int e = sc.nextInt();
students[i] = new Student(id, c, mScore, e);
}
// 计算各科排名
for (int now = 0; now < 4; now++) {
final int currentSubject = now; // 为Lambda表达式创建final变量
// 按当前科目降序排序
Arrays.sort(students, (a, b) -> b.grade[currentSubject] - a.grade[currentSubject]);
// 计算排名(处理同分情况)
int[] ranks = new int[n];
ranks[0] = 1;
for (int i = 1; i < n; i++) {
if (students[i].grade[currentSubject] == students[i-1].grade[currentSubject]) {
ranks[i] = ranks[i-1];
} else {
ranks[i] = i + 1;
}
}
// 存储排名到Map
for (int i = 0; i < n; i++) {
int[] studentRank = rankMap.computeIfAbsent(students[i].id, k -> new int[4]);
studentRank[currentSubject] = ranks[i];
}
}
// 处理查询
StringBuilder sb = new StringBuilder();
for (int i = 0; i < m; i++) {
int queryId = sc.nextInt();
int[] ranks = rankMap.get(queryId);
if (ranks == null) {
sb.append("N/A\n");
} else {
int bestRank = Integer.MAX_VALUE;
int bestCourseIndex = 0;
// 找出最优排名(多个科目并列时按A>C>M>E优先级)
for (int j = 0; j < 4; j++) {
if (ranks[j] < bestRank) {
bestRank = ranks[j];
bestCourseIndex = j;
}
}
sb.append(bestRank).append(" ").append(course[bestCourseIndex]).append("\n");
}
}
System.out.print(sb);
sc.close();
}
}
C++版本
cpp
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct Student{
int id;
int grade[4];
}stu[2010];
char course[4] = {'A','C','M','E'};
int Rank[10000000][4]={0};
int now; //cmp函数中使用
bool cmp(Student a,Student b){
return a.grade[now]>b.grade[now];
}
int main(){
int n,m;
scanf("%d%d",&n,&m);
//读入分数
for(int i=0;i<n;i++){
scanf("%d%d%d%d",&stu[i].id,&stu[i].grade[1],&stu[i].grade[2],&stu[i].grade[3]);
stu[i].grade[0]=round((stu[i].grade[1]+stu[i].grade[2]+stu[i].grade[3])/3.0)+0.5;
}
for(now=0;now<4;now++){
sort(stu,stu+n,cmp);
Rank[stu[0].id][now]=1;//分数最大的
for(int i=1;i<n;i++){//对于剩下的学生
if(stu[i].grade[now] == stu[i-1].grade[now]){
Rank[stu[i].id][now] = Rank[stu[i-1].id][now];
}else{
Rank[stu[i].id][now] = i+1;
}
}
}
int query;//查询
for(int i=0;i<m;i++){
scanf("%d",&query);
if(Rank[query][0]==0){
printf("N/A\n");
}else{
int k=0;
for(int j=0;j<4;j++){
if(Rank[query][j]<Rank[query][k]){
k=j;
}
}
printf("%d %c\n",Rank[query][k],course[k]);
}
}
}