Docker 安装 Elasticsearch 9

参考链接

www.elastic.co/docs/soluti...

环境

操作系统:Ubuntu 24.04 LTS

容器:Docker 28.2.2

ES 版本:最新版(9.0.3)

安装

1)安装 docker【已安装可跳过】

参考:blog.csdn.net/a2497_28226...

2)启动 elasticsearch

若是出现报错请往 Q&A 看

perl 复制代码
# 通过 curl 下载启动脚本 并进行执行
curl -fsSL https://elastic.co/start-local | sh

3)查看是否启动成功

复制代码
docker ps

开启远程访问【可选】

默认是只能本地访问

1)切换到 elastic-start-local 目录

这个目录就在你执行 curl -fsSL elastic.co/start-local | sh 的目录中,

sql 复制代码
cd elastic-start-local

2)修改 docker-compose.yml

复制代码
vim docker-compose.yml

删除(有两处需要删除) 127.0.0.1:

删除后:

3)执行停止脚本

arduino 复制代码
./stop.sh

4)执行启动脚本

bash 复制代码
./start.sh

5)开放端口

因为我是腾讯云的服务器,所以我直接到安全组里面配置了策略

端点用处:

  • 9200:用于 Elasticsearch
  • 5601:用于 Kibana

以下是从 AI 给出的命令:

ini 复制代码
# 永久开放 9200 和 5601 端口,按需打开
sudo firewall-cmd --permanent --add-port=9200/tcp
sudo firewall-cmd --permanent --add-port=5601/tcp
# 重新加载防火墙配置
sudo firewall-cmd --reload
# 可以用于确定是否开放了端口
# 查看当前开放的端口
sudo firewall-cmd --list-all

6)访问

6.1)Elasticsearch 端点

arduino 复制代码
http://服务器ip:9200

6.2)Kibana 端点

arduino 复制代码
http://服务器ip:5601

Q&A

curl: (28) Failed to connect to elastic.co port 443 after 134286 ms: Couldn't connect to server

原因:网络访问不了 elastic.co/start-local

解决

通过浏览器访问下载,然后上传至服务器,前提就是你的电脑能够访问(V P N)到 elastic.co/start-local

相关推荐
分布式存储与RustFS2 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
玉&心2 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing2 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
guo_wen_qiang2 天前
上传本地镜像到harbor中
docker·容器·持续部署
Elasticsearch2 天前
Elastic Observability 的跨项目搜索:通过一个查询搜索所有关联项目
elasticsearch
羑悻的小杀马特2 天前
Dockerfile 全景指南:从入门编写dockerfile到生产环境镜像优化实战,一步步带你从啃透制作指令到镜像制作落地!
docker·dockerfile·镜像制作
BianHuanShiZhe2 天前
docker常见命令
docker
Elasticsearch2 天前
Elasticsearch 中的 agentic 工作流:暂停 AI agent 等待人工审批,72 小时后恢复
elasticsearch
正经教主2 天前
【FDE系列】阶段2:Day 43:Docker Compose — 多容器一键编排
人工智能·docker·fde
忆~遂愿2 天前
本地片库怎么在外面打开?Plex + cpolar 搭一套可远程访问的私人影音库
docker·容器