Docker 安装 Elasticsearch 9

参考链接

Run Elasticsearch locally | Elastic Docs

环境

操作系统:Ubuntu 24.04 LTS

容器:Docker 28.2.2

ES 版本:最新版(9.0.3)

安装

1)安装 docker【已安装可跳过】

参考:Ubuntu 安装 docker-CSDN博客

2)启动 elasticsearch

若是出现报错请往 Q&A 看

复制代码
# 通过 curl 下载启动脚本 并进行执行
curl -fsSL https://elastic.co/start-local | sh

3)查看是否启动成功

复制代码
docker ps

开启远程访问【可选】

默认是只能本地访问

1)切换到 elastic-start-local 目录

这个目录就在你执行 curl -fsSL https://elastic.co/start-local | sh 的目录中,

复制代码
cd elastic-start-local

2)修改 docker-compose.yml

复制代码
vim docker-compose.yml

删除(有两处需要删除) 127.0.0.1:

删除后:

3)执行停止脚本

复制代码
./stop.sh

4)执行启动脚本

复制代码
./start.sh

5)开放端口

因为我是腾讯云的服务器,所以我直接到安全组里面配置了策略

端点用处:

  • 9200:用于 Elasticsearch
  • 5601:用于 Kibana

以下是从 AI 给出的命令:

复制代码
# 永久开放 9200 和 5601 端口,按需打开
sudo firewall-cmd --permanent --add-port=9200/tcp
sudo firewall-cmd --permanent --add-port=5601/tcp
# 重新加载防火墙配置
sudo firewall-cmd --reload
# 可以用于确定是否开放了端口
# 查看当前开放的端口
sudo firewall-cmd --list-all

6)访问

6.1)Elasticsearch 端点

复制代码
http://服务器ip:9200

6.2)Kibana 端点

复制代码
http://服务器ip:5601

Q&A

curl: (28) Failed to connect to elastic.co port 443 after 134286 ms: Couldn't connect to server

原因:网络访问不了 https://elastic.co/start-local

解决

通过浏览器访问下载,然后上传至服务器,前提就是你的电脑能够访问(V P N)到 https://elastic.co/start-local

相关推荐
呉師傅30 分钟前
得力P2500、M2500系列打印机硒鼓加粉及清零方法【纯享版】
运维·网络·windows·电脑
Sayai36 分钟前
Elasticsearch 日志检索 DSL 实战:时间范围查询、字段去重、分钟级统计与最新日志获取
大数据·运维·elasticsearch·搜索引擎·日志分析
天衍四九-44 分钟前
【无标题】
前端·spring boot·mysql·nginx·docker
赵谨言1 小时前
红蓝对抗Docker渗透复盘-技能与产出汇总
docker·容器·eureka
fb_123453 小时前
MySQL运维实战:备份恢复+主从复制+读写分离+MHA高可用(超详细手把手教程)
运维·mysql·oracle
..Dauntless..3 小时前
【Linux】进程地址空间初步理解
linux·运维·服务器
Julien20043 小时前
Docker 网络(一)
linux·运维·服务器·ssh·学习方法
字节跳动的猫4 小时前
LikeShop 积分体系全链路改造:获取规则、订单抵扣与积分商品兑换二开
运维·数据结构
杨云龙UP4 小时前
一次数据库查询缓慢故障复盘:大表数据增长、SQL全表扫描导致系统响应异常
linux·运维·服务器·数据库·sql·mysql
I'mChloe4 小时前
Windows部署BiliNote:Docker安装、AI视频转写、Markdown笔记与cpolar远程访问
人工智能·windows·docker