[运维]宝塔 Apache环境使用CDN获取访客真实IP方法

AI摘要

本文为Apache服务器配置教程,指导用户通过创建httpd-remoteip.conf文件并加载mod_remoteip模块,实现正确获取访客真实IP地址。核心步骤包括:创建配置文件、启用模块、修改主配置并重启服务。

打开后台的文件

进去 /www/server/apache/conf/extra

新建一个名为 httpd-remoteip.conf

在 apache 安装目录 /conf/extra 新建一个名为 httpd-remoteip.conf 的文件,并在此文件内编辑如下内容:

复制代码
RemoteIPHeader X-Forwarded-For
RemoteIPProxiesHeader X-Forwarded-By

好了,这个页面就不需要了 叉掉即可

二、加载并启用 mod_remoteip 模块

在 apache 的配置文件里搜索关键词 remoteip,找到 #LoadModule remoteip_module modules/mod_remoteip.so

删除前方的注释:# 号,并在下一行追加一条定义,用以连接上方我们创建好的配置文件:

Include conf/extra/httpd-remoteip.conf

找到软件商店 apache

点击设置

点击配置文件

搜索 remoteip

增加一行 Include conf/extra/httpd-remoteip.conf

点击保存并重启 apache 服务即可看到网站可正常获取访客 IP。

本机 ip

服务器日志 ip 也从cdn节点变成我本地test了


相关推荐
骇客野人2 小时前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
蓝速科技5 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese6 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky6 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南7 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123457 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人7 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender7 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35008 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南8 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台