ubuntu 因为写错pam.d文件引起的sudo权限丢失

复制代码
sudo: pam_open_session:权限不足
sudo: 策略插件会话初始化失败

首先确定sudo丢失原因,我是因为写错单词引起的 sudo权限丢失,又因为没有root密码;

修复方式:

  • 重启ubuntu,快速按住【Esc】
  • 进入【GRUB】界面选择【Advance options for Ubuntu】
  • 选择【Ubuntu, with Linux 5.15.0-164-generic (recovery mode)】
  • 选择【Root drop to a root shell prompt】模式,(等待时间可能比较长)

回车

此时获取root权限,进行修复

相关推荐
ai小陈13 小时前
GPU服务器租用存储验收:检查点写入与磁盘吞吐实战
运维·服务器·人工智能·ai·ssh·gpu算力
Ivanqhz15 小时前
激活函数在 Transformer 中的作用及各种变体简述
java·linux·数据库·人工智能·深度学习
有毒的教程16 小时前
VMware仅主机模式:物理机 ↔ 虚拟机 文件共享
运维
殷色玫瑰18 小时前
C/C++ 内存管理详解:从内存分布到 new/delete 底层原理
java·linux·c语言·c++
山岚的运维笔记18 小时前
ComfyUI NVIDIA安装教程:官方便携版下载+run_nvidia_gpu.bat启动,8G显存Windows实操
运维·服务器·windows·笔记·prompt·aigc·comfyui
海宇大数据19 小时前
零信任架构实战:基于海宇活体识别V步骤1构建自动化远程公证会话初始化网关
运维·人工智能·架构·自动化
꯭自꯭闭꯭19 小时前
DM7主备升级方案
linux·服务器·数据库
用户41071920132519 小时前
VMware 虚拟机Ubuntu 环境linux远程连接失败
linux
lisanmengmeng19 小时前
Nagios邮件报警的配置
linux·运维·服务器
Ruiery19 小时前
Linux 6.6内核 CPU 深度解析(六):cpufreq
linux·运维·服务器