记一次k8s pod的CrashLoopBackOff错误状态

背景经过:

k8s刚搭建完毕,组建图形界面dashboard时报错

主要原因:firewall仅开放了服务器ip,没有开放k8s pod之间的虚拟ip,网络不通
方法:放通或干脆关闭firewalld

检查pod状态

复制代码
kubectl get pod -n kubernetes-dashboard

注:

  1. 发现有pod不正常,先describe查看一下

查看pod描述

复制代码
kubectl describe pod kubernetes-dashboard-6b8f9cc89c-n7ff4 -n kubernetes-dashboard

注:

  1. 主要看最后面的Events,没发现具体异常,查看pod日志

查看pod日志

复制代码
kubectl logs -f kubernetes-dashboard-6b8f9cc89c-n7ff4 -n kubernetes-dashboard

注:

  1. 发现异常:dial tcp 10.96.0.1:443: connect: no route to host. 是pod内部网络问题导致无法连接

查看防火墙

复制代码
firewall-cmd --list-all

注:

  1. 服务器firewall只放通了192.169.10.0/16网段,pod内部虚拟网络通信是另外一组ip段(tcp 10.96.0.1:443: connect: no route to host)
  2. pod容器之间会创建虚拟网络互相通信。

解决办法:

复制代码
# k8s集群所有节点放通pod虚拟网卡网段
# 建议直接所有节点关闭firewall
systemctl disable firewalld --now

# 然后等待pod重启,或者手动删了重建
kubectl delete -f recommended.yaml
kubectl apply -f recommended.yaml

再次检查

复制代码
kubectl get pod -n kubernetes-dashboard

ps:获取已有pod的yaml

复制代码
kubectl get deploy -o yaml -n kubernetes-dashboard > recommended2.yaml

ps2:尽量用apply不用create

复制代码
create 是一次性创建命令,资源已存在时报错,仅适用于确认资源不存在的场景
apply 是声明式管理命令,支持创建/更新资源,重复执行无故障,是日常使用的首选
核心区别:create 只有创建能力,apply 兼具创建和增量更新能力。

ps3:使用edge浏览器打开自建https网站被拦截问题

复制代码
在浏览器被拦截页面,英文输入 thisisunsafe
相关推荐
java_logo5 小时前
Docker 部署 DeepSeek Harness:轻松搭建局域网里的 AI Agent 平台
运维·docker·容器·ai agent·deepseek·轩辕镜像·deepseekharness
weixin_435247065 小时前
医疗科研“Agent化”:给研究型医院搭AI原生科研平台的3个架构取舍
云原生
安易算力8 小时前
GPU集群调度实践:Slurm/K8s混合部署与GPU共享优化 —— 从批处理到在线推理的统一调度架构
容器·架构·kubernetes
sbjdhjd1 天前
云安全 | Docker 容器逃逸复盘(二):2375 未授权接口如何突破容器管理边界
网络安全·docker·云原生·数据挖掘·开源·云计算·云安全
吴声子夜歌1 天前
Docker入门与实战——初识Docker与容器
docker·容器
MrSYJ1 天前
Docker端口映射咋做的,模拟下。
docker·云原生·kubernetes
张小凡vip1 天前
Kubernetes--k8s---了解和使用configmap挂载配置文件
云原生·容器·kubernetes
bluebonnet271 天前
【docker】容器内映射外部音频驱动
docker·容器·音视频
吴声子夜歌1 天前
Docker入门与实战——核心概念与安装配置
运维·docker·容器
guo_wen_qiang2 天前
docker的备份与迁移
运维·docker·容器