k8s pod启动报错: no route to host

k8s pod kuboard启动报错

查看pod命令

shell 复制代码
kubectl get pods -A
kubectl get pods --all-namespaces

查看报错pod日志

命令:

复制代码
kubectl logs -f -n namespace name
shell 复制代码
time="2023-08-09T13:40:36+08:00" level=error msg="不能获取 AgentEndpointsGet \"http://kuboard-v3/kuboard-api/cluster/default/kind/KubernetesCluster/default/resource/installAgentGetAgentEndpoints\": dial tcp: lookup kuboard-v3 on 10.10.0.10:53: read udp 10.244.219.109:46173->10.10.0.10:53: read: no route to host"
使用环境变量中的参数
KUBOARD_AGENT_REMOTE_PORT_NGINX: 45001
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
curl: (7) Failed to connect to 10.10.0.1 port 443 after 1001 ms: Couldn't connect to server
 
K8S_VERSION:

 
AGENT_VERSION:
{"version":"v3.5.1","buildDate":"2023-01-02 20:51:33"}
 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:04 --:--:--     0curl: (6) Could not resolve host: kuboard-v3
 
访问 kuboard-server 失败 http://kuboard-v3/kuboard-api/cluster/default/kind/KubernetesClusterToken

pod报错都一样: no route to host

原因:

找不到这个路由对应的地址,关闭防火墙,重启k8s,执行下面命令即可。

正常线上是不能关闭防火墙,这个属于pod内部之间的host调用失败,有大神知道的这种情况怎么处理的,

可以在评论区告知一下,谢谢
解决方案:

  1. 关闭防火墙,执行下前面命令
shell 复制代码
systemctl stop kubelet
systemctl stop docker
iptables --flush
iptables -tnat --flush
systemctl start kubelet
systemctl start docker
  1. 开放k8s对应的端口,上面报错是因为443、53端口没有开启
shell 复制代码
firewall-cmd --permanent --add-port=443/tcp
firewall-cmd --permanent --add-port=53/tcp
manager:
firewall-cmd --permanent --add-port=6443/tcp
firewall-cmd --permanent --add-port=2379-2380/tcp
firewall-cmd --permanent --add-port=10250-10252/tcp
firewall-cmd --reload

work nodes:
firewall-cmd --permanent --add-port=10250/tcp
firewall-cmd --permanent --add-port=30000-32767/tcp
firewall-cmd --reload
# 查看所有打开的端口: 
firewall-cmd --zone=public --list-ports

问题解决出处

相关推荐
万博智云OneProCloud6 小时前
GPU 资源池化最佳实践:规划、调度、监控与运营的五步方法
kubernetes·算力调度·ai基础设施·gpu池化·agione·powerone
分布式存储与RustFS10 小时前
纠删码到底吃掉了多少容量:EC:4、EC:8 的利用率与容错怎么算
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
念何架构之路12 小时前
zap日志SugaredLogger 剖析
云原生·golang
LBL122014 小时前
内网容器部署FTP日志监控服务
运维·服务器·容器
阿里云云原生14 小时前
云效智能评审:让团队规则持续生效
云原生
阿里云云原生15 小时前
智能聚类:从海量 Trace 中理解 Agent 的行为和表现
云原生·agent
阿里云云原生15 小时前
云栖丨AI 应用进入生产,开始拼「实时数据智能」
云原生
溜达的大象15 小时前
极空间部署Traggo时间追踪工具:Docker安装、标签管理与cpolar远程访问
运维·docker·容器
脏脏a16 小时前
极空间部署 Dashlet:Docker 搭建私人导航仪表盘,再配置固定公网访问
运维·docker·容器
运维开发王义杰16 小时前
跳出网络与文件系统:Linux CPU 与内存调优的“防假死”实战
云原生