hive插入动态分区数据时,return code 2报错解决

目录

一、完整报错

二、原因

三、其他


一、完整报错

Error while processing statement: FAILED: Execution Error, return code 2 from org.apache.hadoop.hive.ql.exec.mr.MapRedTask

二、原因

大概率是因为没有开启允许动态分区或单次动态分区个数太小了。

sql 复制代码
-- 动态分区前先运行如下语句
set hive.exec.max.dynamic.partitions = 1000;
set hive.exec.max.dynamic.partitions.pernode = 1000;

三、其他

如果上面语句没有解决,可以看下yarn配置,考虑是否是语句占用内存超过配置最大内存等等。

相关推荐
陈年老古董3 小时前
Hive 函数学习笔记(下):窗口函数与经典案例
hive·笔记·学习
天天喝旺仔3 小时前
MySQL 索引原理与慢查询优化实战:从 B+ 树到执行计划调优
数据库·sql·mysql·性能优化
爱吃火鸡面呀3 小时前
DataX 实战:使用 HDFS Reader 读取 Hive ORC 表并输出到 Stream
hive·hadoop·hdfs
专业程序开发源3 小时前
flask家电故障预测系统92491-计算机课程设计/毕业设计
vscode·python·sql·算法·flask·课程设计
yumgpkpm4 小时前
CDP 7.3.1(Cloudera Runtime 7.3.1)VS Acceldata ODP 3.3.6.4 核心引擎详细版本对比
大数据·hive·hadoop·postgresql·zookeeper·spark·hbase
m0_646429974 小时前
MySQL 初始化 SQL 中文乱码问题总结
数据库·sql·mysql
实战派K8S&DB4 小时前
TDSQL 核心模块与进程体系
运维·数据库·分布式·sql·mysql
冰暮流星7 小时前
sql之计算
数据库·sql
imDwAaY15 小时前
一条 SQL 发出去之后,MySQL 到底做了什么?
sql·mysql
刘胡子大叔1 天前
SQL 脚本的导入顺序
数据库·sql