hive插入动态分区数据时,return code 2报错解决

目录

一、完整报错

二、原因

三、其他


一、完整报错

Error while processing statement: FAILED: Execution Error, return code 2 from org.apache.hadoop.hive.ql.exec.mr.MapRedTask

二、原因

大概率是因为没有开启允许动态分区或单次动态分区个数太小了。

sql 复制代码
-- 动态分区前先运行如下语句
set hive.exec.max.dynamic.partitions = 1000;
set hive.exec.max.dynamic.partitions.pernode = 1000;

三、其他

如果上面语句没有解决,可以看下yarn配置,考虑是否是语句占用内存超过配置最大内存等等。

相关推荐
做运维的阿瑞1 分钟前
一个 NULL 让整列姓名消失?MySQL 字符串与日期函数复盘
数据库·sql·mysql
阳光九叶草LXGZXJ1 小时前
达梦数据库-学习-69-DM9主备集群部署
linux·运维·服务器·数据库·sql·学习
在猴站学算法1 小时前
(SQL注入学习)联合查询注入(UNION-Based)
sql·学习·网络安全
小小龙学IT2 小时前
Go 语言 database/sql 标准库深度解析:从连接池到驱动抽象
数据库·sql·golang
Seraphina362 小时前
SQL注入(一)
数据库·经验分享·笔记·sql·网络安全
卷毛迷你猪2 小时前
快速实验篇(B06)页面单跳转化率
大数据·hive·hadoop
白帽攻防录11 小时前
SRC 挖洞:Roundcube 预认证 SQL 注入深度复盘,CVE-2026-48842 preg_replace 转义绕过怎么打穿邮件系统
网络·数据库·sql·网络安全·sql注入
꯭自꯭闭꯭12 小时前
达梦SQL优化相关
linux·运维·数据库·sql
杨云龙UP20 小时前
一次数据库查询缓慢故障复盘:大表数据增长、SQL全表扫描导致系统响应异常
linux·运维·服务器·数据库·sql·mysql
2501_9336707920 小时前
2027 应用统计学秋招选岗指南:统计、SQL、业务指标如何对应岗位
数据库·sql