hive插入动态分区数据时,return code 2报错解决

目录

一、完整报错

二、原因

三、其他


一、完整报错

Error while processing statement: FAILED: Execution Error, return code 2 from org.apache.hadoop.hive.ql.exec.mr.MapRedTask

二、原因

大概率是因为没有开启允许动态分区或单次动态分区个数太小了。

sql 复制代码
-- 动态分区前先运行如下语句
set hive.exec.max.dynamic.partitions = 1000;
set hive.exec.max.dynamic.partitions.pernode = 1000;

三、其他

如果上面语句没有解决,可以看下yarn配置,考虑是否是语句占用内存超过配置最大内存等等。

相关推荐
要开心吖ZSH4 小时前
MySQL 慢 SQL 排查操作手册-个人笔记版
java·笔记·sql·mysql·慢查询
oradh6 小时前
Oracle固定执行计划的方法---SQL Plan Baseline
数据库·sql·oracle
53488736abcdefg7 小时前
Hive 入门&架构原理
hive·hadoop·架构
jnrjian9 小时前
PG dblink 可以借用fdw 名字和密码直接访问
sql
磁场转动100万匹11 小时前
Hive 学习第一天:搞懂它是什么,并搭好可用的环境
hive·hadoop·学习
2601_9603563812 小时前
2027零售商品计划岗能力拆解:统计学、SQL、Excel与业务指标怎么结合
sql·excel·零售
好奇的菜鸟12 小时前
GORM 入门(二):从 database/sql 平滑过渡到 GORM
数据库·sql
这个DBA有点耶12 小时前
关系数据库管理系统选型指南:四步决策框架与主流产品技术路线对比
数据库·sql·程序人生·mysql·database·dba
jason.zeng@150220712 小时前
(七)「固化 Rest 接口 + Text-to-SQL 灵活查询」双模式 Agent 架构教程
数据库·python·sql·ai·架构·langchain·ai编程
磁场转动100万匹13 小时前
Hive 学习第三天:HQL 查询精讲与内置函数实战
hive·hadoop·学习