hive插入动态分区数据时,return code 2报错解决

目录

一、完整报错

二、原因

三、其他


一、完整报错

Error while processing statement: FAILED: Execution Error, return code 2 from org.apache.hadoop.hive.ql.exec.mr.MapRedTask

二、原因

大概率是因为没有开启允许动态分区或单次动态分区个数太小了。

sql 复制代码
-- 动态分区前先运行如下语句
set hive.exec.max.dynamic.partitions = 1000;
set hive.exec.max.dynamic.partitions.pernode = 1000;

三、其他

如果上面语句没有解决,可以看下yarn配置,考虑是否是语句占用内存超过配置最大内存等等。

相关推荐
旺仔不是程序员1 分钟前
LIMIT 1:PostgreSQL 只取一行的高效查询姿势
数据库·后端·sql
知识的搬运工旺仔20 小时前
唯一索引与 NULL 值:PostgreSQL 主键约束与 NULLS NOT DISTINCT
数据库·后端·sql·postgresql
Francek Chen1 天前
【大数据处理与分析】数据仓库Hive:04 数据仓库Hive概述
大数据·数据仓库·hive·hadoop·分布式
想念是会呼吸的鱼1 天前
【ClickHouse 常用 SQL 语句整理】
sql·clickhouse
想念是会呼吸的鱼1 天前
MySQL 常用语法整理
sql·mysql
SelectDB技术团队1 天前
StarRocks 迁移至 Apache Doris 完整指南:三步完成结构、数据与业务平滑切换
数据库·人工智能·sql·clickhouse·apache doris·selectdb·湖仓架构升级
imDwAaY1 天前
MySQL MVCC 详解:原理、版本链、Read View 与可见性判断
数据库·sql·mysql
Moshow郑锴2 天前
从“水库”到“直饮水站”:重新理解 Data Mart 与 Data Lake、Data Lakehouse、Data Warehouse 的区别
数据仓库·data·湖仓一体