hive插入动态分区数据时,return code 2报错解决

目录

一、完整报错

二、原因

三、其他


一、完整报错

Error while processing statement: FAILED: Execution Error, return code 2 from org.apache.hadoop.hive.ql.exec.mr.MapRedTask

二、原因

大概率是因为没有开启允许动态分区或单次动态分区个数太小了。

sql 复制代码
-- 动态分区前先运行如下语句
set hive.exec.max.dynamic.partitions = 1000;
set hive.exec.max.dynamic.partitions.pernode = 1000;

三、其他

如果上面语句没有解决,可以看下yarn配置,考虑是否是语句占用内存超过配置最大内存等等。

相关推荐
Andreapiki6 小时前
数字化审计校招技术备考指南:SQL、Python、BI、RPA学习路径
python·sql·rpa
ha_lydms15 小时前
MaxCompute中加密与解密函数
大数据·数据库·数据仓库·hadoop·dataworks·maxcompute·odps
鼓掌MVP16 小时前
SQL 语句是一个典型的 DDL
sql·ddl
用户2504581060920 小时前
数据库索引为什么会失效?从执行计划理解 SQL 性能优化
sql·mysql
Andreapiki21 小时前
风险审计校招技术栈拆解:SQL、Python、Power BI在2026届JD中的真实权重
数据库·python·sql
weixin_404551241 天前
Oracle SQL 优化知识库:构建方案与价值评估
数据库·sql·oracle
我的愿望是成为富婆1 天前
HR数字化校招技术栈拆解:SQL、Excel、Power BI和AI工具在2026届JD中的真实权重
人工智能·sql·excel
做运维的阿瑞1 天前
一张用户表串懂 MySQL 的库、表、列、行、主键
数据库·sql·mysql·oracle
JosieBook1 天前
【数据库】MySQL 实战精通系列 · 第3篇:SQL 核心与复杂查询实战
数据库·sql·mysql