kafka启动报错

一、kafka启动报错:

复制代码
java.nio.file.FileSystemException: D:\kafka_2.12-2.1.0\kafka_2.12-2.1.0\logs\__consumer_offsets-30\00000000000000000000.timeindex.cleaned: 另一个程序正在使用此文件,进程无法访问。

解决办法:

修改 server.properties,修改配置如下:

复制代码
log.retention.hours=-1
log.cleaner.enable=false

详情见:https://blog.csdn.net/weixin_36771703/article/details/112374609

相关推荐
此时不提桶,更待何时6 小时前
06-18-A-RabbitMQ消息特性与消费机制详解
分布式·rabbitmq
闻哥7 小时前
分布式任务调度框架:XXL-Job / ElasticJob / DolphinScheduler / SchedulerX 架构对比与选型
分布式·架构·wpf
笔墨登场说说7 小时前
centos 8 使用 kafka_2.13-4.3.1.tgz 安装kafka
linux·kafka·centos
明月无心照西山8 小时前
分布式任务系统的监控告警分级与自愈设计——以帮帮星球为例
分布式
guo_wen_qiang8 小时前
kafka一直restarting,报错InconsistentClusterIdException
分布式·kafka
实战派K8S&DB8 小时前
TDSQL 核心模块与进程体系
运维·数据库·分布式·sql·mysql
仍然.8 小时前
Redis---分布式锁
数据库·redis·分布式
小小龙学IT9 小时前
etcd 深度解析:Go 分布式一致性 KV 存储与 Raft 共识实战
分布式·golang·etcd
今年下半年9 小时前
【消息队列】Spring Boot 集成 Kafka 消息队列:确保消费完成(手动提交偏移量+幂等判断+失败重试机制)
spring boot·kafka·幂等·失败重试
小师兄吃牛肉17 小时前
Java 同步系列之 ZooKeeper 分布式锁
java·分布式·java-zookeeper