持续集成交付CICD:Jenkins通过API触发流水线

目录

一、理论

1.HTTP请求

2.调用接口的方法

3.HTTP常见错误码

二、实验

1.Jenkins通过API触发流水线

三、问题

1.如何拿到上一次jenkinsfile文件进行自动触发流水线


一、理论

1.HTTP请求

(1)概念

bash 复制代码
HTTP超文本传输协议,是确保服务器(Server)和客户端(Client)之间的正确通信。

(2)响应过程

bash 复制代码
1)Request 用户通过浏览器向我们的服务端发起请求。
   请求: 客户端   ➡   服务端

2)Response服务端将客户端请求的资源数据进行响应。
   响应: 客户端   ⬅   服务端

一个请求和响应的过程:

2.调用接口的方法

(1)请求类型

bash 复制代码
1)GET 向指定的URL请求资源,可携带参数(明文)。

2)POST 向指定的URL提交资源,表单数据提交,数据进行封装(比Get方法安全)。

3)PUT 与POST类似,通常用于对资源数据的更新修改。

4)DELETE 删除指定的资源。

3.HTTP常见错误码

(1)错误码

bash 复制代码
1xx : 服务已收到请求,请求者继续执行操作

2xx:请求成功,常见(201)

3xx:请求成功,页面发生重定向(301)

4xx:客户端发生了错误
常见的是资源找不到了(404)
资源请求需要认证认证失败(401)
认证成功但是权限不够(403)

5xx: 服务端发生了错误
      网关超时(504)
      内部错误(500)
      网关错误(502)
      服务不可用(503)

二、实验

1.Jenkins通过API触发流水线

(1)postman新建组(day3-apitest)

(2)安装插件

(3)新建文件夹

(4)保存

(5)新建流水线

(6)构建触发器与指定token

(7)保存

(8)postman点击触发

(9)jenkins已触发.

(10)构建成功

(11)可以生成python代码.

(12)生成curl代码

(13)主机复制curl代码

(14)jenkins生成第二次构建

(15)构建成功

(16)postman点击duplicate复制

(17)postman新增body的raw的josn键值对格式

(18)现在也能触发

(19)已触发,但是jenkins并没有消化数据

(20)修改postman的body,列表里嵌套字典

(21)构建触发器,获取2个变量(第一个变量获取第一层的字典,第二个变量获取数组里的字典

(22)开启打印日志功能

(23)编写流水线

(24)postman点击发送

(25)输出成功

(26)修改流水线

(27)postman点击发送

(28)构建成功

(29)postman添加header

(30)jenkins添加header变量

(31)修改流水线打印账户密码

(32)postman点击发送

(33)成功输出

(34)添加Request变量

(35)修改流水线代码

(36)postman添加变量

(37)postman发送

(38)构建成功

三、问题

1.如何拿到上一次jenkinsfile文件进行自动触发流水线

(1)解决方法

①安装rebuilder插件

②新增rebuild按钮

③点击rebuild

④成功

⑤成功拿到上一次jenkinsfile文件

相关推荐
蓝速科技9 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese9 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky9 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南10 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我1234510 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人10 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender11 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly350011 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南12 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
春天花会开13112 小时前
Supabase 自部署 Edge Functions 超时从 60s 延长到 360s 完整复盘
运维·云原生