Two Rabbits,区间dp,最长回文串

Problem - 4745 (hdu.edu.cn)

Problem Description

Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time.

Now they want to find out the maximum turns they can play if they follow the optimal strategy.

Input

The input contains at most 20 test cases.

For each test cases, the first line contains a integer n denoting the number of stones.

The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)

The input ends with n = 0.

Output

For each test case, print a integer denoting the maximum turns.

Sample Input

复制代码

1

1

4

1 1 2 1

6

2 1 1 2 1 3 0

Sample Output

复制代码

1

4

5

Hint

For the second case, the path of the Tom is 1, 2, 3, 4, and the path of Jerry is 1, 4, 3, 2.

For the third case, the path of Tom is 1,2,3,4,5 and the path of Jerry is 4,3,2,1,5.

解析 :

性质:想要满足题目的意思,两只兔子只能在所给序列的最长回文子串上行走

子集划分:f[i][j]:表示区间 i 到 j 内的最长回文子串的长度是多少

状态转移 :

当 a[i]==a[j]: f[i][j]=f[i+1][j-1]+2;

否则:f[i][j]=max(f[i][j-1],f[i+1][j]);

由于题目中的序列是一个环,所以最后需要特殊处理,详细看代码

cpp 复制代码
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>

using namespace std;
typedef long long LL;
const int N = 1e3 + 5;
int n,a[N];
int f[N][N];


int main() {
	while (cin >> n,n) {
		memset(f, 0, sizeof f);
		for (int i = 1; i <= n; i++) {
			scanf("%d", &a[i]);
		}
		for (int i = 1; i <= n; i++) {
			f[i][i] = 1;
		}
		for (int len = 2; len <= n; len++) {
			for (int i = 1; i + len - 1 <= n; i++) {
				int j = i + len - 1;
				if (a[i] == a[j]) {
					f[i][j] = f[i + 1][j - 1] + 2;
				}
				else {
					f[i][j] = max(f[i + 1][j], f[i][j - 1]);
				}
			}
		}
		int ans = 0;
		for (int i = 1; i <= n; i++) {
			ans = max(ans, f[1][i]+ f[i + 1][n]);
		}
		cout << ans << endl;
	}
	return 0;
}
相关推荐
trust Tomorrow20 分钟前
每日一题-力扣-2278. 字母在字符串中的百分比 0331
算法·leetcode
Lecea_L34 分钟前
你能在K步内赚最多的钱吗?用Java解锁最大路径收益算法(含AI场景分析)
java·人工智能·算法
Tony8836 分钟前
热题100 - 394. 字符串解码
java·算法
Lecea_L42 分钟前
🔍 找到数组里的“节奏感”:最长等差子序列
java·算法
是Dream呀44 分钟前
ResNeXt: 通过聚合残差变换增强深度神经网络
人工智能·算法
学习2年半1 小时前
53. 最大子数组和
算法
君义_noip2 小时前
信息学奥赛一本通 1524:旅游航道
c++·算法·图论·信息学奥赛
烁3472 小时前
每日一题(小白)动态规划篇5
算法·动态规划
独好紫罗兰2 小时前
洛谷题单2-P5717 【深基3.习8】三角形分类-python-流程图重构
开发语言·python·算法
滴答滴答嗒嗒滴2 小时前
Python小练习系列 Vol.8:组合总和(回溯 + 剪枝 + 去重)
python·算法·剪枝