EIGRP实验

实验大纲

一、基本配置

1.构建网络拓扑结构图

2.路由器基本配置

3.配置PC

4.测试连通性

5.保存配置文件

二、配置EIGRP

1.查看路由表

2.配置EIGRP动态路由

3.查看路由器路由表

4.测试网络连通性

5.查看所有路由器的路由协议

6.保存配置文件

三、配置OSPF

1.配置路由器ID

2.配置OSPF

3.查看路由信息

4.关闭EIGRP

5.检查路由表并测试网络连通性

6.保存配置

7.测试到各个网络的连通性

一、基本配置

1.构建网络拓扑结构图

2.路由器基本配置

RA#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RA(config)#interface f0/0
RA(config-if)#ip add 172.16.199.1 255.255.255.128
RA(config-if)#no shut
RA(config-if)#interface s0/0
RA(config-if)#ip add 172.16.199.225 255.255.255.252
RA(config-if)#clock rate 2000000
RA(config-if)#no shut

RC#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RC(config)#interface f0/0
RC(config-if)#ip add 172.16.199.129 255.255.255.192
RC(config-if)#no shut
RC(config-if)#int s0/0
RC(config-if)#ip add 172.16.199.230 255.255.255.252
RC(config-if)#no shut

RB#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RB(config)#int f0/0
RB(config-if)#ip add 172.16.199.193 255.255.255.224
RB(config-if)#no shut
RB(config-if)#int s0/0
RB(config-if)#ip add 172.16.199.226 255.255.255.252
RB(config-if)#no shut
RB(config-if)#int s0/1
RB(config-if)#ip add 172.16.199.229 255.255.255.252
RB(config-if)#no shut

3.配置PC

4.测试连通性

RA ping PCA 和RB

RB ping PCB、RA 和 RC

RC ping PCC 和 RB

5.保存配置文件

RA#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]

RB#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]

RC#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]

二、配置EIGRP

1.查看路由表

show ip route

2.配置EIGRP动态路由

# 在RA上配置EIGRP
RA(config)#router eigrp 333     #启动EIGRP进行
RA(config-router)#no auto-summary       #取消自动汇总 
RA(config-router)#network 172.16.0.0    #通告网络
RA(config-router)#passive-interface f0/0    #被动接口

RB(config)#router eigrp 333
RB(config-router)#no auto-summary 
RB(config-router)#network 172.16.0.0
RB(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 333: Neighbor 172.16.199.225 (Serial0/0) is up: new adjacency
​
RB(config-router)#passive-interface f0/0
RB(config-router)#end

RC(config)#router eigrp 333
RC(config-router)#no auto-summary 
RC(config-router)#network 172.16.0.0
RC(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 333: Neighbor 172.16.199.229 (Serial0/0) is up: new adjacency
​
RC(config-router)#passive-interface f0/0

3.查看路由器路由表

show ip route

4.测试网络连通性

在各个路由器测试到各个PC机的连通性

RA到PCA、PCB 和 PCC

RB到PCA、PCB 和 PCC

RC到PCA、PCB 和 PCC

5.查看所有路由器的路由协议

show ip protocols

6.保存配置文件

RA#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]

RB#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]

RC#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]

三、配置OSPF

为了使OSPF易于识别路由器而使网络管理和故障排除更加容易,利用Loopback接口设置路由器的ID; 在各路由器配置OSPF动态路由; 再检查路由信息,并与之前做比较; 测试和检验网络连通性。 注:反掩码用255.255.255.255减去子网掩码获得。

1.配置路由器ID

RA#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RA(config)#int loopback 0
​
RA(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
​
RA(config-if)#ip add 10.199.1.1 255.255.255.255
RA(config-if)#exit

RB#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RB(config)#int loopback 0
​
RB(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
​
RB(config-if)#ip add 10.199.2.2 255.255.255.255
RB(config-if)#exit

RC#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RC(config)#int loopback 0
​
RC(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
​
RC(config-if)#ip add 10.199.3.3 255.255.255.255
RC(config-if)#exit

2.配置OSPF

RA(config)#router ospf 100
RA(config-router)#network 172.16.199.0 0.0.0.127 area 0
RA(config-router)#network 172.16.199.224 0.0.0.3 area 0
RA(config-router)#end

RB(config)#router ospf 200
RB(config-router)#network 172.16.199.192 0.0.0.31 area 0
RB(config-router)#network 172.16.199.224 0.0.0.3 area 0
RB(config-router)#end

RC(config)#router ospf 300
RC(config-router)#network 172.16.199.128 0.0.0.63 area 0
RC(config-router)#network 172.16.199.228 0.0.0.3 area 0
RC(config-router)#end

3.查看路由信息

show ip route

起作用的仍为EIGRP动态路由

此时EIGRP和OSPF同时进行,因为他们的管理距离分别是90和110,所以EIGRP优先起作用。查看路由表可以验证。为了使OSPF起作用,必须关闭EIGRP。然后检查路由表,并与之前做比较。

4.关闭EIGRP

RA(config)#no route eigrp 333

RB(config)#no route eigrp 333

RC(config)#no route eigrp 333

5.检查路由表并测试网络连通性

show ip route
show ip protocols

6.保存配置

7.测试到各个网络的连通性

RA到PCA

RB到PCB

RC到PCC

相关推荐
Miraitowa_cheems2 小时前
[JavaEE] UDP协议
网络·tcp/ip·java-ee
网络研究院2 小时前
人工智能有助于解决 IT/OT 集成安全挑战
网络·人工智能·安全·报告·工业·状况
花果山~~程序猿4 小时前
高级I/O知识分享【5种IO模型 || select || poll】
运维·服务器·网络
码哝小鱼5 小时前
firewalld实现NAT端口转发
linux·网络
网络研究院5 小时前
执行网络攻击模拟的 7 个步骤
网络·安全·web安全·攻击·模拟·实践·步骤
一fan风顺5 小时前
BGP实验
网络
RememberLey5 小时前
【VitualBox】VitualBox的网络模式+网络配置
linux·网络·virtualbox
u0109053596 小时前
黑群晖安装教程
网络