SQL Server :已成功与服务器建立连接,但是在登录前的握手期间发生错误。

SQL Server 登录数据库报错:已成功与服务器建立连接,但是在登录前的握手期间发生错误。

学习sqlserver的时候,默认的身份验证是windows的身份验证。

而在进一步学习的时候希望改成sqlserver的身份验证。操作流程无非就是选中服务器------》右击属性

再按如下图选择,当然sqlserver有默认的身份验证账号,sa,操作教程也有,这里不谈。我也是按如此操作的

当然我画蛇添足的选择,讲最大并发连接数改成了2,导致出现问题:已成功与服务器建立连接,但是在登录前的握手期间发生错误。

看之前博主说出现该错误的原因就是因为最大并发数的问题,那么修改最大并发数就可以避免该错误,可是问题是,当出现该错误的时候,我们往往操作不了服务器。

经验下来的操作就是,1、不停重启服务器,重启之后试试属性是否可以调试。2、不停断开再连接,连接后试试属性是否可以调试。

修改连接数为0,问题即可解决。

解决了这个问题,那么为什么最大并发数不为0就会出现这个错误?

1、最大并发连接是什么概念?

sqlserver中的最大并发连接数(max pool size)就是你能同时有多少个到sqlserver数据库的连接。

默认是100, 理论最大为32767,

2、为什么数量过低会出现上述错误

来自微软:https://learn.microsoft.com/zh-cn/sql/connect/ado-net/sql-server-connection-pooling?view=sql-server-ver16

啥意思呢?

就是说我们逻辑上同过程序和数据库建立连接,其实是一种极耗费资源的过程

为了减少资源消耗,提高利用率

sqlserver采用了一个新技术------连接池

这个连接池是什么意思呢?

池程序维持物理连接的所有权。 通过为每个给定的连接配置保留一组活动连接来管理连接。 每当用户在连接上调用 Open 时,池进程就会查找池中可用的连接。 如果某个池连接可用,会将该连接返回给调用者,而不是打开新连接。 应用程序在该连接上调用 Close 时,池进程会将连接返回到活动连接池集中,而不是关闭连接。 连接返回到池中之后,即可在下一个 Open 调用中重复使用。

所以程序当中建立连接,和我们在ssms中的操作(如下图)实际上是从池中找可用的链接。当最大并发连接数很大,那么查找的范围更多,更有可能找到物理链接开启的链接。反之则越少。

所以测试的时候也尽可能将数量设的更多一点。

相关推荐
树下水月19 分钟前
Typora破解
linux·服务器·前端
沫璃染墨1 小时前
《从零入门Linux系统篇(五十七):线程篇·十——生产者消费者模型进阶:从环形缓冲区到POSIX信号量》
linux·运维·服务器·开发语言·c++·系统架构·信号处理
路远的数据库笔记1 小时前
SQL Server迁移国产数据库怎么做?九套口岸库零停机割接实战
数据库·经验分享·sqlserver·dba
HAHAXX81 小时前
电商RPA批量上架通用方案:一套流程如何同时跑通拼多多、抖店、淘宝和跨境平台
java·运维·rpa
零基础1232 小时前
LLM Agent 驱动的物模型构建:从设备手册到边缘接入的自动化实践
运维·人工智能·经验分享·python·自动化
星夜夏空992 小时前
网络编程(5)—— Reactor实现(v3)
服务器·网络·php
程序猿老A3 小时前
从入门型到企业型:云服务器开放共享型到独享型规格升级
运维·服务器
Ruiery4 小时前
Linux 6.6内核 CPU 深度解析(九):时钟与 TSC — 内核怎么从 PIT/HPET 切到 TSC
linux·运维·服务器
吴声子夜歌4 小时前
Nginx应用与运维——Nginx监控配置及管理(二)
运维·nginx
吴声子夜歌4 小时前
Nginx应用与运维——Nginx日志管理
java·运维·nginx