docker 容器中安装cron,却无法启动定时任务

问题描述:

当我是在Dockerfile配置安装cron

RUN apt-get update && apt-get install -y cron

或者进入容器中安装cron

apt-get install -y cron

都会有个问题就是cron服务正常启动,但是加入到/etc/con.d下的任务,或者crontab -e 添加的定时任务都没有运行。

问题原因:

大概是因为没有添加上环境变量。

解决问题:

写个sh 脚本用来添加定时任务,顺便在重启cron时添加环境变量。

需要给sh 脚本加上运行权限

chmod +x xxx.sh

bash 复制代码
#!/bin/bash
# crontab
cp /home/cronfile /etc/cron.d/cronfile
chmod 0644 /etc/cron.d/cronfile
crontab /etc/cron.d/cronfile
service cron restart
printenv | grep -v "no_proxy" >> /etc/environment

cronfile中定义自己的任务

bash 复制代码
*/1 * * * * date >> /var/log/time.log 2>&1
相关推荐
骇客野人2 小时前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
九皇叔叔5 小时前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s
蓝速科技5 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese5 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky6 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南7 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123457 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人7 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender7 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35008 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器